summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@googlemail.com>2014-08-08 01:55:33 +0200
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2014-08-08 09:24:00 +0200
commit779ae371b152748aecf2ea81eca1bdbbf0226389 (patch)
treebb617dd73d7c5eed7fd5ef777c926a138e22c5cf /configure.ac
parentextract shaders to own file and use shared shader loading (diff)
downloadcore-779ae371b152748aecf2ea81eca1bdbbf0226389.tar.gz
core-779ae371b152748aecf2ea81eca1bdbbf0226389.zip
reuse OpenGLContext in OGL canvas
The only thing that needs to be reimplemented is the pbuffer based custom sprite rendering. We should use a FBO with a texture backend for that. This will also save several OpenGL context switches! Change-Id: I4aef33ae2499e44c8b5f41c296d8721cb94a37a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ee388ea6866d..38cb6bd136fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10556,8 +10556,7 @@ if test "x$enable_opengl" = "xno"; then
elif test "$_os" = "Darwin"; then
# We use frameworks on Mac OS X, no need for detail checks
ENABLE_OPENGL=TRUE
- ENABLE_OPENGL_CANVAS=
- add_warning "openGL canvas not adapted for Mac yet - disabling"
+ ENABLE_OPENGL_CANVAS=TRUE
SYSTEM_MESA_HEADERS=TRUE
AC_MSG_RESULT([yes])
elif test $_os = WINNT; then