summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2014-08-08 16:07:24 +0200
committerStephan Bergmann <sbergman@redhat.com>2014-08-08 16:07:24 +0200
commit5ab1098d5fbc1ba092da73af2b92e5bcdd7a3f8d (patch)
treec4ea52b01613165a535056c00020f1b8538fcabe /configure.ac
parentbnc#885548: Set the date time mode to non-fixed after the import is done. (diff)
downloadcore-5ab1098d5fbc1ba092da73af2b92e5bcdd7a3f8d.tar.gz
core-5ab1098d5fbc1ba092da73af2b92e5bcdd7a3f8d.zip
Generalize -fsanitize=address checks
...that are at least also relevant for -fsanitize=undefined Change-Id: I39044d2a73912a605af8e965eb1cdf8dfd4f0051
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index dc9f86ab6191..38c2ea97b6f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1021,9 +1021,8 @@ AC_ARG_ENABLE(runtime-optimizations,
[Statically disable certain runtime optimizations (like rtl/alloc.h or
JVM JIT) that are known to interact badly with certain dynamic analysis
tools (like -fsanitize=address or Valgrind). By default, disabled iff
- CC contains "-fsanitize=address". (For Valgrind, those runtime
- optimizations are typcially disabled dynamically via
- RUNNING_ON_VALGRIND.)]))
+ CC contains "-fsanitize=*". (For Valgrind, those runtime optimizations
+ are typcially disabled dynamically via RUNNING_ON_VALGRIND.)]))
AC_ARG_ENABLE(compiler-plugins,
AS_HELP_STRING([--enable-compiler-plugins],
@@ -5680,7 +5679,7 @@ AC_MSG_CHECKING([whether to enable runtime optimizations])
if test -z "$enable_runtime_optimizations"; then
for i in $CC; do
case $i in
- -fsanitize=address)
+ -fsanitize=*)
enable_runtime_optimizations=no
break
;;
@@ -6566,13 +6565,14 @@ _ACEOF
if ! $CXX $CXXFLAGS $CPPFLAGS $LINKFLAGSSHL -fPIC -fvisibility-inlines-hidden conftestlib1.cc -o libconftest1$DLLPOST >/dev/null 2>&5; then
gccvisinlineshiddenok=no
else
- dnl At least Clang -fsanitize=address is known to not work with
- dnl -z defs (unsetting which makes the test moot, though):
+ dnl At least Clang -fsanitize=address and -fsanitize=undefined are
+ dnl known to not work with -z defs (unsetting which makes the test
+ dnl moot, though):
my_linkflagsnoundefs=$LINKFLAGSNOUNDEFS
if test "$COM_GCC_IS_CLANG" = TRUE; then
for i in $CXX; do
case $i in
- -fsanitize=address)
+ -fsanitize=*)
my_linkflagsnoundefs=
break
;;