summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@gmail.com>2013-03-18 12:09:49 +0100
committerMatúš Kukan <matus.kukan@gmail.com>2013-03-18 12:12:23 +0100
commit40f92a3cbe817db09d10eff856002962c0b5e906 (patch)
tree87738f95c1f5df716230a66d050d541b0193421e /configure.ac
parentFix crash in fdo#62119 (diff)
downloadcore-40f92a3cbe817db09d10eff856002962c0b5e906.tar.gz
core-40f92a3cbe817db09d10eff856002962c0b5e906.zip
use only internal python on cygwin
Change-Id: Ibcfa5030a245e1bbc00c01c4d42a5bba01ec9aa9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 95f548ac6f2f..18490cf415d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7264,12 +7264,14 @@ AC_SUBST([MINGW_ZLIB_DLL])
# Optionally user can pass an option to configure, i. e.
# ./configure PYTHON=/usr/bin/python
# =====================================================================
-# This allows a lack of system python with no error, we use internal one in that case.
-AM_PATH_PYTHON([2.6],, [:])
-# Clean PYTHON_VERSION checked below if cross-compiling
-PYTHON_VERSION=""
-if test "$PYTHON" != ":"; then
- PYTHON_FOR_BUILD=$PYTHON
+if test "$build_os" != "cygwin"; then
+ # This allows a lack of system python with no error, we use internal one in that case.
+ AM_PATH_PYTHON([2.6],, [:])
+ # Clean PYTHON_VERSION checked below if cross-compiling
+ PYTHON_VERSION=""
+ if test "$PYTHON" != ":"; then
+ PYTHON_FOR_BUILD=$PYTHON
+ fi
fi
AC_SUBST(PYTHON_FOR_BUILD)