summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLionel Elie Mamane <lionel@mamane.lu>2014-08-11 13:03:27 +0200
committerLionel Elie Mamane <lionel@mamane.lu>2014-08-11 13:51:38 +0200
commit35836d2494d67d129f305e2294fc60fed062c9c7 (patch)
tree5172b13baf29c8619fffec754f4cf30a217596e7 /configure.ac
parentRelated: fdo#82259 add Armenian preview text (diff)
downloadcore-35836d2494d67d129f305e2294fc60fed062c9c7.tar.gz
core-35836d2494d67d129f305e2294fc60fed062c9c7.zip
switch internal mariadb client to version 2
and reenable it: hopefully the worst bugs are fixed now Change-Id: I8033ef87d02ba6619e5f778b5255fa803ba63c5b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7126012bc59d..0e88287a7127 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8244,12 +8244,11 @@ if test "$ENABLE_MARIADBC" = "TRUE"; then
if test "$with_system_mariadb" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_MARIADB=TRUE
- #AC_PATH_PROG(MARIADBCONFIG, [mariadb_config])
+ AC_PATH_PROG(MARIADBCONFIG, [mariadb_config])
if test -z "$MARIADBCONFIG"; then
AC_PATH_PROG(MARIADBCONFIG, [mysql_config])
if test -z "$MARIADBCONFIG"; then
- #AC_MSG_ERROR([mariadb_config and mysql_config are missing. Install MariaDB or MySQL package.])
- AC_MSG_ERROR([mysql_config is missing. Install MySQL client library development package.])
+ AC_MSG_ERROR([mariadb_config and mysql_config are missing. Install MariaDB or MySQL development package.])
fi
fi
AC_MSG_CHECKING([MariaDB version])
@@ -8302,7 +8301,6 @@ if test "$ENABLE_MARIADBC" = "TRUE"; then
fi
else
AC_MSG_RESULT([internal])
- AC_MSG_ERROR([libmariadb is known to be broken as of 2013-10; use libmysqlclient])
SYSTEM_MARIADB=
MARIADB_CFLAGS="-I${WORKDIR}/UnpackedTarball/mariadb/include"
MARIADB_LIBS="-L${WORKDIR}/LinkTarget/StaticLibrary -lmariadblib"