summaryrefslogtreecommitdiffstats
path: root/canvas
Commit message (Collapse)AuthorAgeFilesLines
* bnc#681110: Fix squashed glyphs with Cairo canvas.Jan Holesovsky2012-11-091-23/+2
| | | | | | | | | | | | | I suppose it is the same misconception as in fdo#55931 - I am convinced that the font metrics should not be used here. Looks to me as if in the past, the font width computation was broken somewhere deep inside OOo, and everyone instead of fixing the root cause was just working that around by using the FontMetric; and then one day the root cause was fixed, and all the workarounds broke ;-) - but that is just a theory. Change-Id: I741bf8f4eaea4f7d8bc698dc9a8124109dfb8c20 Signed-off-by: Thorsten Behrens <tbehrens@suse.com>
* Resolves: fdo#47432 Improve the "faux bold" in cairo canvasFlex Liu2012-11-091-2/+3
| | | | | | | | The "faux bold" make the bold font in Asian ugly & unacceptable, Adjust & improve the "faux bold" to make the bold font better. Change-Id: I2e02156ffc30629476b80134ffb0b50e793f7ead Signed-off-by: Jan Holesovsky <kendy@suse.cz>
* fix fdo#51547: revert "Some cppcheck cleaning"Michael Meeks2012-07-043-10/+10
| | | | This reverts commit 2f804c94cdaaa9ac047f229509c774dbea1dbcaa.
* use generic names rather than specific algorithm names when scalingLuboš Luňák2012-06-222-2/+2
| | | | | | | | | | | | | | | | | The Lanczos scaling is of very good quality, but it's rather slow, which can be very noticeable with large images, so it's not a very good default for everything. And in general, it's not good to refer to a specific algorithm when all one usually wants is fast/default/best. Some of these changes are a bit of a guess between default/best, but the general logic is that best should be used only for images that won't be large or where the possible waiting does not matter. Conflicts: svtools/source/graphic/grfmgr2.cxx Change-Id: I53765507ecb7ed167890f6dd05e73fe53ffd0231
* fdo#30519 paint scrolled area from the right surfaceDavid Tardon2012-06-182-15/+53
| | | | | | | | | | This adds a way to test whether mpCompositeSurface contains the front buffer image, so it can be used as a source in painting operations. It means the mpCompositeSurface changed status from 'temporary' to 'persistent' (which it was anyway, from implementation POV :-) Change-Id: Iee4fc7a97cd60e47d0abb148e7337f0b50cabb40 Signed-off-by: David Tardon <dtardon@redhat.com>
* OSL_TRACE -> SAL_INFODavid Tardon2012-06-181-5/+5
| | | | | Change-Id: Icc6f47cc76dfa6716fc44f6c1b5f1b11ba1443c6 Signed-off-by: David Tardon <dtardon@redhat.com>
* Get rid of GRADIENT_* defines, they conflict with Windows GDI types.Jan Holesovsky2012-06-171-4/+0
| | | | | Change-Id: Ia0bc37f81b7213b20fc5093beb46d7a05b1ac931 Signed-off-by: Markus Mohrhard <markus.mohrhard@googlemail.com>
* Use BMP_SCALE_LANCZOS instead of BMP_SCALE_INTERPOLATE.Jan Holesovsky2012-06-052-2/+2
| | | | | | | Where we explicitly ask for better quality, use BMP_SCALE_LANCZOS, instead of BMP_SCALE_INTERPOLATE. Change-Id: I28ddf3290204532a8660e09ee9ab0949b6ce1c73
* targeted string re-workNorbert Thiebaud2012-06-021-5/+5
| | | | Change-Id: I73abfa24f5bb7f25afddef820bb4725bf7cee359
* Some cppcheck cleaningJulien Nabet2012-05-283-10/+10
| | | | Change-Id: Id5be3a25fc66d2f7fcec8325491a23d6908021fc
* remove unneeded include of boost/bind.hppCaolán McNamara2012-05-162-3/+2
| | | | Change-Id: I5a254459a491b9547530d8e312260dceed21f25c
* Related: fdo#48961 don't crash on silly pixmap sizesCaolán McNamara2012-05-091-1/+19
| | | | Change-Id: I43dbe846160d19b203ad6bed06e807d4fbf7ce56
* Remove unused method canvas::tools::clipBlitJordi Mallach2012-05-032-32/+0
|
* rework callcatcher makefile to build subsequentcheck testsCaolán McNamara2012-05-012-11/+0
| | | | Change-Id: Idda0262e62e42817b8c0502a38ee16913495233c
* Some removing in cairocanvasJulien Nabet2012-04-304-22/+0
| | | | Change-Id: Idd08fd733670f4410349a45de882710b19a31f67
* make gbuild the default assumption of build.plBjoern Michaelsen2012-04-291-1/+0
| | | | | | | | this removes dmake completely out of the build for migrated modules build.pl now assumes modules to be gbuild, unless there is a prj/dmake file Change-Id: I674a036b182ee13c5ec093e83cb3d38133112d3b
* Updated canvas readme to contemporary state of things.Thorsten Behrens2012-04-261-50/+20
|
* Add trolling commentsTor Lillqvist2012-04-261-1/+7
|
* WaE: msvc2008 unused formal parameterCaolán McNamara2012-04-261-1/+1
|
* bomb out compilation of cairo canvas for mac or windowsMichael Meeks2012-04-231-0/+4
| | | | This is to avoid unintended regressions based on configure options.
* Nah, don't obscure the right type with void*Tor Lillqvist2012-04-151-1/+1
|
* Copy and adapt current state of Norbert's CoreText work for iOSTor Lillqvist2012-04-151-1/+5
| | | | | | | Compiles, but I obviously have no idea how it works yet. Yes, eventually we should factor out common parts from the iOS and MacOSX code.
* unusedcode.easy: remove various methodsThomas Arnhold2012-04-122-9/+0
|
* add .5 to control points coordinates after transformationRadek Doulik2012-04-121-2/+4
| | | | | - otherwise we might end up with wrong coordinates - fixes fdo#38580
* Remove unused constructor for ParametricPolyPolygonGábor Stefanik2012-04-102-21/+0
|
* Remove canvas::tools::calcRectToRectTransformJulien Nabet2012-04-092-83/+1
|
* Replaced a few equal calls with ==Szabolcs Dezsi2012-04-081-2/+1
|
* LinkTarget.mk: remove gb_LinkTarget_add_package_headersMichael Stahl2012-04-081-1/+1
|
* gbuild: "use" vs. "add":Michael Stahl2012-04-089-25/+25
| | | | | | | | | Naming convention for gbuild methods: - "add" is used for stuff that is logically a part of the target (i.e. not registered at the Module, but defined in the target's makefile) - "use" is used for stuff that is logically a different target (i.e. it is registered at the Module, has it's own makefile, may be in a different module than the target)
* Replaced equalsAsciiL(RTL_CONSTASCII_STRINGPARAM(...)) with == operatorSzabolcs Dezsi2012-04-061-3/+2
|
* Replaced equalsAsciiL(RTL_CONSTASCII_STRINGPARAM(...)) with == operatorSzabolcs Dezsi2012-04-061-10/+10
| | | | | | Pattern used: find . -name "*.cxx" -exec sed -i 's/\( *\)\(else if\|if\) *( *\([^!()|&]*\)\.equalsAsciiL( *RTL_CONSTASCII_STRINGPARAM *( *\([^)]*\)) *) *)$/\1\2 ( \3 == \4 )/' \{\} \;
* Replaced equalsAsciiL(RTL_CONSTASCII_STRINGPARAM(...)) with == operatorSzabolcs Dezsi2012-04-0618-18/+18
| | | | | | Pattern used: find . -name "*.cxx" -exec sed -i 's/\( *\)return \([^()]*\)\.equalsAsciiL( *RTL_CONSTASCII_STRINGPARAM *( *\([^)]*\) ) *);/\1return \2 == \3;/' \{\} \;
* UniString::CreateFromInt32 -> rtl::OUString::valueOfCaolán McNamara2012-04-053-12/+12
|
* removed duplicate includes in avmedia / basic / canvas / chart2 / comphelperTakeshi Abe2012-03-282-3/+0
|
* removed duplicate includes in basic / canvas / chart2 / comphelperTakeshi Abe2012-03-261-1/+0
|
* compile these with exceptions againLuboš Luňák2012-03-171-1/+1
| | | | | a13a88bd2c673d059b60e339dcf3b8fabf991f18 changes them to build without exceptions by mistake, causing a boost problem
* Add missing component file for canvas.Thorsten Behrens2012-03-161-0/+36
|
* Cleanup formatting in cairocanvasThorsten Behrens2012-03-1619-589/+649
| | | | | White-space changes - code was in parts unreadable after tab/spaces conversion. While at it, removed a few lines of commented-out code.
* Add COMPHELPER_SERVICEDECL_EXPORTS* back in, after libmerge changesThorsten Behrens2012-03-167-55/+10
| | | | Did I mention I hate boilerplate copied all over the place? ;)
* Use transparency for gradients fdo#45219Thorsten Behrens2012-03-162-41/+42
| | | | | vclcanvas has 1bpp alpha - so cut-off transparency at 98% This looks for all practical cases close enough to full alpha.
* Return proper transparency value even for ignore_color.Thorsten Behrens2012-03-161-12/+12
| | | | | Rather unexpectedly, calling setupOutDevState() with IGNORE_COLOR does not return a proper transparency, but null. Fixed now.
* Make sure mask is rendered opaque in vclcanvas.Thorsten Behrens2012-03-161-0/+1
|
* Remove nasty xor hack for non-Mac vclcanvasThorsten Behrens2012-03-161-52/+0
| | | | This nowadays really is a pessimization.
* Another partial fix for fdo#45219Thorsten Behrens2012-03-161-17/+11
| | | | | Make sure transparent polygons really only cover the polygonal area, not the whole bounding box for sprites.
* Consistent use of alpha in cairocanvasThorsten Behrens2012-03-161-4/+4
| | | | | Use GetIndex() instead of GetBlue() (does the same, but more self-documenting); use opaque when no alpha channel consistently.
* fdo#47246: canvas: split out static library directxcanvasMichael Stahl2012-03-144-30/+71
|
* Enable -Wnon-virtual-dtor for GCC 4.6Stephan Bergmann2012-03-145-0/+15
| | | | | | | | | | | | | | ...which has the necessary features to support it. Change a lot of classes to either contain a protected non-virtual dtor (which is backwards compatible, so even works for cppumaker-generated UNO headers) or a public virtual one. cppuhelper/propertysetmixin.hxx still needs to disable the warning, as the relevant class has a non-virtual dtor but friends, which would still cause GCC to warn. Includes a patch for libcmis, intended to be upstreamed.
* gbuild: get rid of realpath in gb_Foo_set_includeMatúš Kukan2012-03-106-6/+6
|
* Remove unused codeElton Chung2012-02-252-172/+0
|
* Fix fdo#45219 wrong transparency for animated objects.Thorsten Behrens2012-02-223-5/+4
| | | | | | With the attachement from said bug, and cairocanvas, sprites are displayed multiple times above each other (which, for semi- transparent sprites, lead to incorrect overall transparency)