summaryrefslogtreecommitdiffstats
path: root/shell/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'shell/meson.build')
-rw-r--r--shell/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/shell/meson.build b/shell/meson.build
new file mode 100644
index 000000000000..976c399f47bd
--- /dev/null
+++ b/shell/meson.build
@@ -0,0 +1,15 @@
+localebe_lib = shared_library('localebe',
+ 'source/backends/localebe/localebackend.cxx',
+ 'source/backends/localebe/localebecdef.cxx',
+ udk_fake_h, off_fake_h,
+ cpp_args: ['-DLIBO_INTERNAL_ONLY'],
+ include_directories: [main_inc, udkh_inc, offapi_inc, 'inc'],
+ link_with: [cppu_lib,
+ cppuhelper_lib,
+ sal_lib,
+ i18nlangtag_lib,
+ ],
+ dependencies: [],
+ gnu_symbol_visibility: 'hidden',
+ install: true,
+)