summaryrefslogtreecommitdiffstats
path: root/sc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sc/meson.build')
-rw-r--r--sc/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/sc/meson.build b/sc/meson.build
index 41628cdc1d05..895fdf3a9aa3 100644
--- a/sc/meson.build
+++ b/sc/meson.build
@@ -1,3 +1,19 @@
+scslots_hxx = custom_target('scslots',
+ output: 'scslots.hxx',
+ input: 'sdi/scslots.sdi',
+ depfile: '@BASENAME@.d',
+ command: [svidl_bin,
+ '-quiet',
+ '-I' + meson.current_source_dir() + '/sdi',
+ '-I' + meson.current_source_dir() + '/inc',
+ '-I' + meson.source_root() + '/svx/sdi',
+ '-I' + meson.source_root() + '/sfx2/sdi',
+ '-I' + meson.source_root() + '/include',
+ '-fs' + meson.build_root() + '/@OUTPUT@',
+ '-fM' + meson.build_root() + '/@DEPFILE@',
+ '-fm' + meson.current_build_dir(),
+ meson.build_root() + '/@INPUT@'])
+
sc_lib = shared_library('sclo',
'source/core/data/attarray.cxx',
'source/core/data/attrib.cxx',
@@ -588,6 +604,7 @@ sc_lib = shared_library('sclo',
'source/core/tool/arraysumSSE2.cxx',
# Formula logger.
'source/core/tool/formulalogger.cxx',
+ scslots_hxx,
udk_fake_h, off_fake_h, oovba_fake_h,
cpp_args: ['-DSC_DLLIMPLEMENTATION',
'-DSC_INFO_OSVERSION="linux"',