summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0fd12811585b..fa01b8853df9 100644
--- a/meson.build
+++ b/meson.build
@@ -25,6 +25,12 @@ if host_machine.system() == 'linux'
add_global_arguments('-DX86_64', language: 'cpp')
add_global_arguments('-DX86_64', language: 'c')
add_global_arguments('-DCPPU_ENV=gcc3', language: 'cpp')
+ add_global_arguments('-DOSL_DEBUG_LEVEL=1', language: 'cpp')
+ add_global_arguments('-DOSL_DEBUG_LEVEL=1', language: 'c')
+ add_global_arguments('-DSAL_LOG_INFO', language: 'cpp')
+ add_global_arguments('-DSAL_LOG_INFO', language: 'c')
+ add_global_arguments('-DSAL_LOG_WARN', language: 'cpp')
+ add_global_arguments('-DSAL_LOG_WARN', language: 'c')
rtl_os = 'Linux'
elif host_machine.system() == 'windows'
# HACK: just random values thrown in to make