summaryrefslogtreecommitdiffstats
path: root/cppu/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'cppu/meson.build')
-rw-r--r--cppu/meson.build14
1 files changed, 10 insertions, 4 deletions
diff --git a/cppu/meson.build b/cppu/meson.build
index 0ac31d2a86a1..3bbd1fba57cc 100644
--- a/cppu/meson.build
+++ b/cppu/meson.build
@@ -1,4 +1,4 @@
-cppu_lib = shared_library('cppulo',
+cppu_lib = shared_library('uno_cppu',
'source/cppu/compat.cxx',
'source/cppu/cppu_opt.cxx',
'source/threadpool/current.cxx',
@@ -21,9 +21,15 @@ cppu_lib = shared_library('cppulo',
'source/uno/sequence.cxx',
udk_fake_h,
include_directories: [main_inc, udkh_inc],
- cpp_args: ['-DLIBO_INTERNAL_ONLY',
- '-DCPPU_DLLIMPLEMENTATION'],
- link_with: [salhelper_lib, sal_lib],
+ cpp_args: [
+ '-DCPPU_DLLIMPLEMENTATION',
+ '-DLIBO_INTERNAL_ONLY',
+ ],
+ link_with: [
+ sal_lib,
+ salhelper_lib,
+ ],
+ soversion : '3',
gnu_symbol_visibility: 'hidden',
install: true,
)