summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d83d4a8f52fc..0ffc61c1db0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8639,6 +8639,9 @@ dnl ===================================================================
if test "$_os" = "WINNT"; then
AC_MSG_CHECKING([whether to enable build of Mozilla addressbook connectivity driver for Windows])
if test "$enable_win_mozab_driver" = "yes" -a "$WITH_MINGW" != "YES" ; then
+ if test "$BITNESS_OVERRIDE" = 64; then
+ AC_MSG_ERROR([--with-win-mozab-driver and --enable-64-bit options are mutually exclusive])
+ fi
WITH_MOZAB4WIN=TRUE
AC_MSG_RESULT([yes, internal (old windows mozab driver)])
BUILD_TYPE="$BUILD_TYPE MOZ"