summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e739513c0b33..83e4b6c3e10a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -701,6 +701,11 @@ darwin*|macos*) # macOS
# -undefined error is the default
LINKFLAGSNOUNDEFS=""
+ if test "$host_cpu" = arm64; then
+ # HOST_PLATFORM is used for external projects and their configury occasionally doesn't like
+ # the "macos" part so be sure to use arm64-apple-darwin for now.
+ HOST_PLATFORM=arm64-apple-darwin
+ fi
;;
ios*) # iOS