summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 92cbf7eedc6d..0d2b8aca01a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10151,8 +10151,11 @@ if test "$_os" = "Linux" -o "$_os" = "Darwin"; then
[AC_MSG_ERROR([gpgme headers not found, install gpgme development package])], [])
else
AC_MSG_RESULT([internal])
- BUILD_TYPE="$BUILD_TYPE LIBGPGERROR LIBASSUAN GPGMEPP"
AC_DEFINE([GPGME_CAN_EXPORT_MINIMAL_KEY])
+ BUILD_TYPE="$BUILD_TYPE LIBGPGERROR LIBASSUAN GPGMEPP"
+ if test "$_os" = "WINNT"; then
+ BUILD_TYPE="$BUILD_TYPE GLIB2"
+ fi
GPG_ERROR_CFLAGS="-I${WORKDIR}/UnpackedTarball/libgpg-error/src"
GPG_ERROR_LIBS="-L${WORKDIR}/UnpackedTarball/libgpg-error/src/.libs -lgpg-error"