summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac87
1 files changed, 40 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index cdf0ecadf3d9..5dcd90191ddd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1970,7 +1970,7 @@ AC_ARG_WITH(linker-hash-style,
AC_ARG_WITH(jdk-home,
AS_HELP_STRING([--with-jdk-home=<absolute path to JDK home>],
- [If you have installed JDK 8 or later on your system please supply the
+ [If you have installed JDK 9 or later on your system please supply the
path here. Note that this is not the location of the java command but the
location of the entire distribution.]),
,)
@@ -7278,20 +7278,12 @@ if test "$ENABLE_JAVA" != ""; then
reg_get_value "$bitness" "HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/JDK/$ver/JavaHome"
_jdk_home=$regvalue
fi
- if test -z "$with_jdk_home"; then
- for ver in 1.8; do
- reg_get_value "$bitness" "HKEY_LOCAL_MACHINE/SOFTWARE/JavaSoft/Java Development Kit/$ver/JavaHome"
- if test -n "$regvalue"; then
- _jdk_home=$regvalue
- break
- fi
- done
- fi
+
if test -f "$_jdk_home/lib/jvm.lib" -a -f "$_jdk_home/bin/java.exe"; then
with_jdk_home="$_jdk_home"
howfound="found automatically"
else
- AC_MSG_ERROR([No JDK found, pass the --with-jdk-home option pointing to a $bitness-bit JDK])
+ AC_MSG_ERROR([No JDK found, pass the --with-jdk-home option pointing to a $bitness-bit JDK >= 9])
fi
else
test "$build_os" = "cygwin" && with_jdk_home=`win_short_path_for_make "$with_jdk_home"`
@@ -7373,24 +7365,7 @@ if test "$ENABLE_JAVA" != ""; then
elif test `$JAVAINTERPRETER -version 2>&1 | $AWK '{ print }' | $GREP -c "BEA"` -gt 0; then
AC_MSG_ERROR([No valid check available. Please check the block for your desired java in configure.ac])
elif test `$JAVAINTERPRETER -version 2>&1 | $AWK '{ print }' | $GREP -c "IBM"` -gt 0; then
- JDK=ibm
-
- dnl IBM JDK specific tests
- _jdk=`$JAVAINTERPRETER -version 2>&1 | $AWK -F'"' '{ print \$2 }' | $SED s/[[-A-Za-z]]*//`
- _jdk_ver=`echo "$_jdk" | $AWK -F. '{ print (($1 * 100) + $2) * 100 + $3;}'`
-
- if test "$_jdk_ver" -lt 10800; then
- AC_MSG_ERROR([IBM JDK is too old, you need at least 8])
- fi
-
- AC_MSG_RESULT([found (IBM JDK $_jdk)])
-
- if test "$with_jdk_home" = ""; then
- AC_MSG_ERROR([In order to successfully build LibreOffice using the IBM JDK,
-you must use the "--with-jdk-home" configure option explicitly])
- fi
-
- JAVA_HOME=$with_jdk_home
+ AC_MSG_ERROR([No valid check available. Please check the block for your desired java in configure.ac])
else
JDK=sun
@@ -7398,10 +7373,10 @@ you must use the "--with-jdk-home" configure option explicitly])
_jdk=`$JAVAINTERPRETER -version 2>&1 | $AWK -F'"' '{ print \$2 }' | $SED '/^$/d' | $SED s/[[-A-Za-z]]*//`
_jdk_ver=`echo "$_jdk" | $AWK -F. '{ print (($1 * 100) + $2) * 100 + $3;}'`
- if test "$_jdk_ver" -lt 10800; then
- AC_MSG_ERROR([JDK is too old, you need at least 8])
+ if test "$_jdk_ver" -lt 10900; then
+ AC_MSG_ERROR([JDK is too old, you need at least 9])
fi
- if test "$_jdk_ver" -gt 10800; then
+ if test "$_jdk_ver" -gt 10900; then
JAVA_CLASSPATH_NOT_SET=TRUE
fi
@@ -7417,7 +7392,7 @@ you must use the "--with-jdk-home" configure option explicitly])
JAVAFLAGS=-J-Xmx128M
fi
else
- AC_MSG_ERROR([Java not found. You need at least JDK 8])
+ AC_MSG_ERROR([Java not found. You need at least JDK 9])
fi
else
dnl Java disabled
@@ -10521,18 +10496,8 @@ if test "x$enable_gtk3" = "xyes"; then
[AC_MSG_ERROR(EGL headers not found. install mesa-libEGL-devel)], [])
fi
fi
-AC_SUBST(GTK3_LIBS)
-AC_SUBST(GTK3_CFLAGS)
AC_SUBST(ENABLE_GTK3)
-if test "$enable_introspection" = yes; then
- if test "$ENABLE_GTK3" = TRUE; then
- GOBJECT_INTROSPECTION_REQUIRE(INTROSPECTION_REQUIRED_VERSION)
- else
- AC_MSG_ERROR([--enable-introspection requires --enable-gtk3])
- fi
-fi
-
ENABLE_QT5=""
if test "x$enable_qt5" = "xyes"; then
ENABLE_QT5="TRUE"
@@ -10551,11 +10516,39 @@ AC_SUBST(ENABLE_KF5)
ENABLE_GTK3_KDE5=""
if test "x$enable_gtk3_kde5" = "xyes"; then
- ENABLE_GTK3_KDE5="TRUE"
- AC_DEFINE(ENABLE_GTK3_KDE5)
- R="$R gtk3_kde5"
+ if test "$with_system_cairo" = no; then
+ AC_MSG_ERROR([System cairo required for gtk3 support, do not combine --enable-gtk3 with --without-system-cairo])
+ fi
+ : ${with_system_cairo:=yes}
+ PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.18 gtk+-unix-print-3.0 gmodule-no-export-2.0 glib-2.0 >= 2.38 cairo, ENABLE_GTK3_KDE5="TRUE", ENABLE_GTK3_KDE5="")
+ if test "x$ENABLE_GTK3_KDE5" = "xTRUE"; then
+ AC_DEFINE(ENABLE_GTK3_KDE5)
+ R="$R gtk3_kde5"
+ else
+ AC_MSG_ERROR([gtk3_kde5 or dependent libraries of the correct versions, not found])
+ fi
+ GTK3_CFLAGS=$(printf '%s' "$GTK3_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
+ FilterLibs "${GTK3_LIBS}"
+ GTK3_LIBS="${filteredlibs}"
+
+ dnl We require egl only for the gtk3 plugin. Otherwise we use glx.
+ if test "$with_system_epoxy" != "yes"; then
+ AC_CHECK_LIB(EGL, eglMakeCurrent, [:], AC_MSG_ERROR([libEGL required.]))
+ AC_CHECK_HEADER(EGL/eglplatform.h, [],
+ [AC_MSG_ERROR(EGL headers not found. install mesa-libEGL-devel)], [])
+ fi
fi
AC_SUBST(ENABLE_GTK3_KDE5)
+AC_SUBST(GTK3_LIBS)
+AC_SUBST(GTK3_CFLAGS)
+
+if test "$enable_introspection" = yes; then
+ if test "$ENABLE_GTK3" = "TRUE" -o "$ENABLE_GTK3_KDE5" = "TRUE"; then
+ GOBJECT_INTROSPECTION_REQUIRE(INTROSPECTION_REQUIRED_VERSION)
+ else
+ AC_MSG_ERROR([--enable-introspection requires --enable-gtk3])
+ fi
+fi
if test "$_os" = "WINNT"; then
R="$R win"
@@ -10685,7 +10678,7 @@ AC_SUBST(SYSTEM_BLUEZ)
dnl ===================================================================
dnl Check whether to enable GIO support
dnl ===================================================================
-if test "$ENABLE_GTK3" = "TRUE"; then
+if test "$ENABLE_GTK3" = "TRUE" -o "$ENABLE_GTK3_KDE5" = "TRUE"; then
AC_MSG_CHECKING([whether to enable GIO support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_gio" = "yes"; then
dnl Need at least 2.26 for the dbus support.