summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9a13921411ce..eb569d10afe7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11805,7 +11805,10 @@ AC_SUBST(CAIRO_LIBS)
dnl ===================================================================
dnl Test whether to use avahi
dnl ===================================================================
-if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_avahi" = "yes"; then
+if test "$_os" = "WINNT"; then
+ # Windows uses bundled mDNSResponder
+ BUILD_TYPE="$BUILD_TYPE MDNSRESPONDER"
+elif test "$_os" != "Darwin" -a "$enable_avahi" = "yes"; then
PKG_CHECK_MODULES([AVAHI], [avahi-client >= 0.6.10],
[ENABLE_AVAHI="TRUE"])
AC_DEFINE(HAVE_FEATURE_AVAHI)