summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 0 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac
index 2cf3ebf543d0..4a0dac756da6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6394,45 +6394,6 @@ if test "$cxx11_utf16_string_literal" = yes; then
AC_DEFINE([HAVE_CXX11_UTF16_STRING_LITERAL])
fi
-AC_MSG_CHECKING([whether $CXX supports C++14 sized deallocation])
-dnl At least Clang -fsanitize=address causes "multiple definition of
-dnl `operator delete(void*, unsigned long)'" also defined in
-dnl projects/compiler-rt/lib/asan/asan_new_delete.cc:
-save_CXX=$CXX
-if test "$COM_IS_CLANG" = TRUE; then
- my_CXX=
- for i in $CXX; do
- case $i in
- -fsanitize=address)
- ;;
- *)
- my_CXX="$my_CXX $i"
- ;;
- esac
- done
- CXX=$my_CXX
-fi
-save_CXXFLAGS=$CXXFLAGS
-CXXFLAGS="$CXXFLAGS $CXXFLAGS_CXX11"
-AC_LANG_PUSH([C++])
-AC_RUN_IFELSE([AC_LANG_PROGRAM([[
- #include <cstddef>
- #include <cstdlib>
- void operator delete(void *) throw () { std::exit(1); }
- void operator delete(void *, std::size_t) throw () { std::exit(0); }
- struct S { S() { throw 0; } };
- ]],[[
- try { new S; } catch (...) {}
- return 1;
- ]])], [cxx14_sized_deallocation=yes], [cxx14_sized_deallocation=no], [cxx14_sized_deallocation=no])
-AC_LANG_POP([C++])
-CXX=$save_CXX
-CXXFLAGS=$save_CXXFLAGS
-AC_MSG_RESULT([$cxx14_sized_deallocation])
-if test "$cxx14_sized_deallocation" = yes; then
- AC_DEFINE([HAVE_CXX14_SIZED_DEALLOCATION])
-fi
-
HAVE_GCC_PRAGMA_OPERATOR=
dnl _Pragma support (may require C++11)
if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then