summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000000..934511d4939f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,35 @@
+# few needed variables
+
+stampdir = $(top_builddir)/build/stamp
+pkgconfigdir = $(libdir)/pkgconfig
+ooo_prefix = @OOO_PREFIX@
+solverdir = $(ooo_prefix)/solver
+
+# rules to execute
+
+all-local: $(stampdir)/all
+
+bootstrap: $(stampdir)/bootstrap
+
+distclean-local:
+ ( . ./Linux*Env.Set.sh ; dmake distclean )
+
+clean-local:
+ ( . ./Linux*Env.Set.sh ; dmake clean )
+
+install-data-local: $(stampdir)/all
+ mkdir -p $(ooo_prefix)
+ mkdir -p $(pkgconfigdir)
+ cp -a $(top_builddir)/solenv $(ooo_prefix)/
+ cp -a $(top_builddir)/solver $(ooo_prefix)/
+ $(INSTALL_SCRIPT) $(top_builddir)/Linux*Env.Set.sh $(solverdir)/
+ $(INSTALL_DATA) $(top_builddir)/build/src/OpenOffice.org-bootstrap.pc $(pkgconfigdir)/
+
+$(stampdir)/all: $(stampdir)/bootstrap
+ ( . ./Linux*Env.Set.sh ; \
+ export ULFEX=$(abs_srcdir)/build/bin/noulf ; \
+ export ULFCONV=$(abs_srcdir)/build/bin/noulfconv ; \
+ cd build ; build.pl --all ) && touch $@
+
+$(stampdir)/bootstrap: Linux*Env.Set.sh
+ ( . ./Linux*Env.Set.sh ; ./bootstrap ) && touch $@