summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2012-05-08 17:20:42 +0200
committerStephan Bergmann <sbergman@redhat.com>2012-05-08 18:18:43 +0200
commita2d9f7178d4516f7d0f21f3d699dff9940697409 (patch)
tree75516f2305056475cd2b3d60d40a6b5a67efc9e8 /configure.in
parentn#757651 vcl: sync GenericSalLayout and SimpleWinLayout with MultiSalLayout (diff)
downloadcore-a2d9f7178d4516f7d0f21f3d699dff9940697409.tar.gz
core-a2d9f7178d4516f7d0f21f3d699dff9940697409.zip
Proper quoting
Change-Id: I4ac3e017f1450a14d2bb389b72ffd2e69cc5767a
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 750899b8fd99..1ee1ba105130 100644
--- a/configure.in
+++ b/configure.in
@@ -3739,11 +3739,13 @@ if test -z "$GNUMAKE"; then
fi
fi
-for a in "$MAKE" $GNUMAKE make gmake gnumake; do
- $a --version 2> /dev/null | grep GNU 2>&1 > /dev/null
- if test $? -eq 0; then
- GNUMAKE=$a
- break
+for a in "$MAKE" "$GNUMAKE" make gmake gnumake; do
+ if test -n "$a"; then
+ $a --version 2> /dev/null | grep GNU 2>&1 > /dev/null
+ if test $? -eq 0; then
+ GNUMAKE=$a
+ break
+ fi
fi
done
AC_MSG_RESULT($GNUMAKE)