summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHans-Joachim Lankenau <hjs@openoffice.org>2010-02-08 19:08:31 +0100
committerHans-Joachim Lankenau <hjs@openoffice.org>2010-02-08 19:08:31 +0100
commitfbe449d1fded69d7b22f121fff3f1c4a5b9b533c (patch)
treea2e06a4a7c73630faf483aac6f9df6ec2966853e /configure.in
parentause110: #i106731# new dir to check (diff)
parent#i10000# latest and greatest configure (diff)
downloadcore-fbe449d1fded69d7b22f121fff3f1c4a5b9b533c.tar.gz
core-fbe449d1fded69d7b22f121fff3f1c4a5b9b533c.zip
ause110: update to DEV300_m71
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 16 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 044019637bb8..0abc5937682d 100644
--- a/configure.in
+++ b/configure.in
@@ -389,6 +389,10 @@ AC_ARG_WITH(beanshell-jar,
[ --with-beanshell-jar=JARFILE Specify path to jarfile manually ],
[ BSH_JAR="$withval"
])
+AC_ARG_ENABLE(presenter-extra-ui,
+[ --enable-presenter-extra-ui enables extra functionality during slideshow,
+ e.g. selecting pen color, erasing drawings etc.
+],,enable_presenter_extra_ui=no)
AC_ARG_ENABLE(minimizer,
[ --enable-minimizer enables the build of the Presentation Minimizer extension
],,)
@@ -3515,7 +3519,7 @@ AC_SUBST(BUILD_QADEVOOO)
dnl ===================================================================
dnl Check for prelinked libgcc_s.so.1
dnl ===================================================================
-if test -z "$with_system_stdlibs" -a -z "$with_system_libs"; then
+if test "$_os" = "Linux" -a -z "$with_system_stdlibs" -a -z "$with_system_libs"; then
if test -n "$checkforstdlibproblems"; then
if test -f /etc/rpm/macros.prelink; then
with_system_stdlibs=yes
@@ -4500,12 +4504,6 @@ if test "$_os" = "WINNT" -o "$_os" = "Linux" && test "z$enable_graphite" == "z"
AC_MSG_RESULT([external])
SYSTEM_GRAPHITE=YES
PKG_CHECK_MODULES( GRAPHITE, silgraphite )
- AC_MSG_CHECKING([STL compatibility])
- if test "$WITH_STLPORT" != "no"; then
- AC_MSG_ERROR([to use system graphite you need to use --without-stlport])
- else
- AC_MSG_RESULT([OK])
- fi
else
AC_MSG_RESULT([internal])
SYSTEM_GRAPHITE=NO
@@ -4898,6 +4896,7 @@ if test -n "$with_system_altlinuxhyph" -o -n "$with_system_libs" && \
else
AC_MSG_RESULT([internal])
SYSTEM_HYPH=NO
+ BUILD_TYPE="$BUILD_TYPE HYPHEN"
fi
AC_SUBST(SYSTEM_HYPH)
AC_SUBST(HYPHEN_LIB)
@@ -5559,6 +5558,16 @@ fi
AC_SUBST(ENABLE_OPENGL)
+AC_MSG_CHECKING([whether to build extra presenter ui])
+if test -n "$enable_presenter_extra_ui" -a "$enable_presenter_extra_ui" != "no"; then
+ AC_MSG_RESULT([yes])
+ ENABLE_PRESENTER_EXTRA_UI=YES
+else
+ AC_MSG_RESULT([no])
+ ENABLE_PRESENTER_EXTRA_UI=NO
+fi
+AC_SUBST(ENABLE_PRESENTER_EXTRA_UI)
+
AC_MSG_CHECKING([whether to build the Presentation Minimizer extension])
if test -n "$enable_minimizer" -a "$enable_minimizer" != "no"; then
AC_MSG_RESULT([yes])