summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorsb <sb@openoffice.org>2010-02-25 09:10:21 +0100
committersb <sb@openoffice.org>2010-02-25 09:10:21 +0100
commiteffed40ee9822d032cb506a25090f7e8b8dfa574 (patch)
tree6aeef92c162367799ba64966fa5aa5b05da6193d /configure.in
parentsb118: more typos (diff)
downloadcore-effed40ee9822d032cb506a25090f7e8b8dfa574.tar.gz
core-effed40ee9822d032cb506a25090f7e8b8dfa574.zip
sb118: improved JAVAIFLAGS settings (to work on Mac OS X Tiger as well as Snow Leopard)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 29cbb5ff60df..8ea1f00cbe86 100644
--- a/configure.in
+++ b/configure.in
@@ -2704,6 +2704,17 @@ if test "$SOLAR_JAVA" != ""; then
fi
JAVAINTERPRETER=`cygpath -d "$JAVAINTERPRETER"`
JAVAINTERPRETER=`cygpath -u "$JAVAINTERPRETER"`
+ elif test "$_os" = "Darwin"; then
+ dnl HACK: There currently is only a 32 bit version of OOo for Mac OS X,
+ dnl and Tiger java complains about -d32 while Snow Leopard java needs it
+ dnl to run in 32 bit mode and be able to load OOo jnilibs:
+ AC_MSG_CHECKING([whether to pass -d32 to Java interpreter])
+ if "$JAVAINTERPRETER" -d32 >&5 2>&5; then
+ AC_MSG_RESULT([yes])
+ JAVAIFLAGS=-d32
+ else
+ AC_MSG_RESULT([no])
+ fi
fi
fi
@@ -3086,6 +3097,7 @@ AC_SUBST(JAVA_HOME)
AC_SUBST(JDK)
AC_SUBST(JAVAFLAGS)
AC_SUBST(JAVAINTERPRETER)
+AC_SUBST(JAVAIFLAGS)
AC_SUBST(JAVACOMPILER)
AC_SUBST(JAVAAOTCOMPILER)
AC_SUBST(JAVADOC)