summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJens-Heiner Rechtien <hr@openoffice.org>2010-04-13 13:11:00 +0200
committerJens-Heiner Rechtien <hr@openoffice.org>2010-04-13 13:11:00 +0200
commitc0572a8a1b7b7419502090ee89667ba3e217e394 (patch)
treeda610e0e36b53ace6eea9c028b9754a725fdf94d /configure.in
parentCWS-TOOLING: integrate CWS ause110 (diff)
parentcmcfixes73: #i110077# silence soltools warnings (diff)
downloadcore-c0572a8a1b7b7419502090ee89667ba3e217e394.tar.gz
core-c0572a8a1b7b7419502090ee89667ba3e217e394.zip
CWS-TOOLING: integrate CWS cmcfixes73
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in73
1 files changed, 65 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index dab96e0a3f5f..33bd0d829d11 100644
--- a/configure.in
+++ b/configure.in
@@ -381,7 +381,7 @@ AC_ARG_ENABLE(mysql-connector,
AC_ARG_WITH(system-mysql,
[ --with-system-mysql Use MySQL libraries already on system, for building the MySQL Connector/OOo extension.
Requires MYSQLCONFIG to point to the mysql_config executable.
-],,with_system_mysql="no")
+],,)
AC_ARG_WITH(libmysql-path,
[ --with-libmysql-path Use Connector/C (libmysql) installation for building the MySQL Connector/OOo extension.
@@ -3960,13 +3960,6 @@ int main(int argc, char **argv) {
], [AC_MSG_RESULT(OK)], [AC_MSG_ERROR([not suitable, we need >= 1.0.6])])
AC_LANG_POP([C++])
- AC_MSG_CHECKING([STL compatibility])
- if test "$WITH_STLPORT" != "no"; then
- AC_MSG_ERROR([to use system mysqlcppconn you need to use --without-stlport])
- else
- AC_MSG_RESULT([OK])
- fi
-
else
AC_MSG_RESULT([internal])
AC_MSG_CHECKING([for mysqlcppconn module])
@@ -4083,6 +4076,70 @@ if test -n "$with_system_saxon" -o -n "$with_system_libs" && \
[AC_MSG_ERROR(serializer.jar not found.)], [])
AC_SUBST(SERIALIZER_JAR)
fi
+
+dnl Saxon comes in two practically available versions, the out-of-date saxonb which
+dnl supports the java extensions that OOo uses, and the up-to-date saxon he
+dnl "home edition" version, which is crippled to not support those java extensions.
+dnl And as an aside the he one also needs to be tweaked to include
+dnl a META-INF/services to broadcast that it supports the jaxp transform factory
+
+ AC_MSG_CHECKING([if saxon works])
+ cat > saxontest.java <<_ACEOF
+[import javax.xml.transform.TransformerFactory;
+import javax.xml.transform.Transformer;
+import javax.xml.transform.stream.StreamSource;
+import java.io.*;
+
+import net.sf.saxon.FeatureKeys;
+
+class saxontest {
+ public static void main(String[] args) {
+ System.setProperty("javax.xml.transform.TransformerFactory",
+ "net.sf.saxon.TransformerFactoryImpl");
+ try {
+ TransformerFactory tfactory = TransformerFactory.newInstance();
+ // some external saxons (Debian, Ubuntu, ...) have this disabled
+ // per default
+ tfactory.setAttribute(FeatureKeys.ALLOW_EXTERNAL_FUNCTIONS, new Boolean(true));
+ System.out.println("TransformerFactory is" +
+ tfactory.getClass().getName());
+ Transformer transformer = tfactory.newTransformer(
+ new StreamSource(new File(args[0])));
+ } catch(Exception e){
+ e.printStackTrace(System.err);
+ System.exit(-1);
+ }
+ System.exit(0);
+ }
+}
+]
+_ACEOF
+ cat > saxontest.xsl<<_ACEOF
+[<?xml version="1.0" encoding="UTF-8"?>
+<xsl:stylesheet version="2.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
+ <xsl:template match="/">
+ <xsl:value-of select="math:sqrt(1)" xmlns:math="java:java.lang.Math"/>
+ </xsl:template>
+</xsl:stylesheet>
+]
+_ACEOF
+ javac_cmd="$JAVACOMPILER -cp $SAXON_JAR saxontest.java 1>&2"
+ AC_TRY_EVAL(javac_cmd)
+ if test $? = 0 && test -f ./saxontest.class ; then
+ java_cmd="$JAVAINTERPRETER -cp $SAXON_JAR:. saxontest saxontest.xsl 1>&2"
+ AC_TRY_EVAL(java_cmd)
+ if test $? = 0; then
+ AC_MSG_RESULT([yes])
+ else
+ cat saxontest.java >&5
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([Non-functional saxon jar, e.g. crippled saxon-he instead of saxonb])
+ fi
+ else
+ AC_MSG_RESULT([no])
+ cat saxontest.java >&5
+ AC_MSG_ERROR([saxontest could not be compiled, non-functional saxon jar])
+ fi
else
AC_MSG_RESULT([internal])
SYSTEM_SAXON=NO