summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHans-Joachim Lankenau <hjs@openoffice.org>2010-01-15 14:55:12 +0100
committerHans-Joachim Lankenau <hjs@openoffice.org>2010-01-15 14:55:12 +0100
commita96692642a1653de11782a98abe0ba5cd6779269 (patch)
treeb411ba7d98f956f7e7935def1fac2f52eedf06ae /configure.in
parent#i10000# more accurate error message (diff)
downloadcore-a96692642a1653de11782a98abe0ba5cd6779269.tar.gz
core-a96692642a1653de11782a98abe0ba5cd6779269.zip
ause110: #i106731# remove tarballs from scm and find them in download cache dir
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 17cc81f905f5..7a1b99a5313f 100644
--- a/configure.in
+++ b/configure.in
@@ -35,6 +35,13 @@ AC_ARG_ENABLE(ldap,
[ --disable-ldap Disables the use of LDAP backend via Netscape/Mozilla
or OpenLDAP LDAP SDK
],,)
+AC_ARG_ENABLE(fetch-external,
+[ --disable-fetch-external Disables fetching external tarballs from web sources
+],,)
+AC_ARG_WITH(external-tar,
+[ --with-external-tar=<TARFILE PATH> Specify path to tarfiles manually ],
+[ TARFILE_LOCATION="$withval"
+])
AC_ARG_WITH(openldap,
[ --with-openldap Enables the use of the OpenLDAP LDAP SDK instead
of the Netscape/Mozilla one
@@ -6751,6 +6758,18 @@ fi
AC_SUBST(VERBOSE)
dnl ===================================================================
+dnl external tarballs.
+dnl ===================================================================
+if test -z $TARFILE_LOCATION; then
+ TARFILE_LOCATION="DEFAULT"
+fi
+AC_SUBST(TARFILE_LOCATION)
+
+if test -z "$enable_fetch_external" || test "$enable_fetch_external" = "yes"; then
+ DO_FETCH_TARBALLS="yes"
+fi
+AC_SUBST(DO_FETCH_TARBALLS)
+dnl ===================================================================
dnl Setting up the environment.
dnl ===================================================================
echo "********************************************************************"