summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mst@openoffice.org>2010-03-09 13:27:16 +0100
committerMichael Stahl <mst@openoffice.org>2010-03-09 13:27:16 +0100
commit9f99b9bb3ce89207f74de7393e592b25bd923332 (patch)
tree066c42c53e3366248d440dd29d142f5b9dc62fce /configure.in
parentDEV300 (diff)
downloadcore-9f99b9bb3ce89207f74de7393e592b25bd923332.tar.gz
core-9f99b9bb3ce89207f74de7393e592b25bd923332.zip
odfmetadata4: #i108911#: configure.in: enable with-system-redland:
based on patch by cmc. no patches are required for redland any more, so enable system redland. minimum version is redland 1.0.8.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index be384fb3adc3..17d96d91a0f7 100644
--- a/configure.in
+++ b/configure.in
@@ -542,6 +542,9 @@ AC_ARG_WITH(system-altlinuxhyph,
AC_ARG_WITH(system-lpsolve,
[ --with-system-lpsolve Use lpsolve already on system
],,)
+AC_ARG_WITH(system-redland,
+[ --with-system-redland Use redland library already on system
+],,)
AC_ARG_WITH(system-mozilla,
[ --with-system-mozilla Use mozilla already on system. Note that some
components cannot be built against a contemporary
@@ -4933,16 +4936,12 @@ dnl ===================================================================
dnl Check for system redland
dnl ===================================================================
AC_MSG_CHECKING([which redland library to use])
-dnl if test -n "$with_system_redland" -o -n "$with_system_libs" && \
-dnl test "$with_system_redland" != "no"; then
-dnl mst: NOTE: right now we need patches against redland
-dnl so we only enable system redland if explicitly requested
-dnl if next version includes patches, insert version check here
-if test -n "$with_system_redland" && \
+if test -n "$with_system_redland" -o -n "$with_system_libs" && \
test "$with_system_redland" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_REDLAND=YES
- PKG_CHECK_MODULES(REDLAND, redland)
+ dnl versions before 1.0.8 write RDF/XML that is useless for ODF (@xml:base)
+ PKG_CHECK_MODULES(REDLAND, redland >= 1.0.8)
else
AC_MSG_RESULT([internal])
BUILD_TYPE="$BUILD_TYPE REDLAND"