summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@openoffice.org>2010-03-04 10:44:35 +0100
committerRene Engelhard <rene@openoffice.org>2010-03-04 10:44:35 +0100
commit8fe75b63d75073a1711f7fd566be11037d2c72d0 (patch)
tree1f3f5a0758d9da667143ce74d3f4eb18b37124b6 /configure.in
parentsb118: fix cut'n'waste error (s/libwpd/cppunit/( (diff)
downloadcore-8fe75b63d75073a1711f7fd566be11037d2c72d0.tar.gz
core-8fe75b63d75073a1711f7fd566be11037d2c72d0.zip
sb118: we need the same STL as cppunit, so we need --without-stlport. Add check... :(
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9afad7672a14..8d1015441097 100644
--- a/configure.in
+++ b/configure.in
@@ -3593,6 +3593,12 @@ if test -n "$with_system_cppunit" -o -n "$with_system_libs" && \
# a system-cppunit before the first version using a proper cppunit
# (and that being 1.12.1) anyway
PKG_CHECK_MODULES( CPPUNIT, cppunit >= 1.12.1 )
+ AC_MSG_CHECKING([STL compatibility])
+ if test "$WITH_STLPORT" != "no"; then
+ AC_MSG_ERROR([to use system cppunit you need to use --without-stlport])
+ else
+ AC_MSG_RESULT([OK])
+ fi
else
AC_MSG_RESULT([internal])
SYSTEM_CPPUNIT=NO