summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorsb <sb@openoffice.org>2010-03-26 13:48:29 +0100
committersb <sb@openoffice.org>2010-03-26 13:48:29 +0100
commit8fa58bb6e7c867f9af76033c18f11c1a9dcabd90 (patch)
tree463b76de9636280815bb338a0481fcc427739079 /configure.in
parentsb121: #i110203# further improvements to packregistry.xslt (diff)
downloadcore-8fa58bb6e7c867f9af76033c18f11c1a9dcabd90.tar.gz
core-8fa58bb6e7c867f9af76033c18f11c1a9dcabd90.zip
sb120: #i106059# handle case correctly when no explicit --with[out]-system-python is given
(transplanted from e66f992d250510fdd587b64aee80352a667d52f6)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 73c64175c2fc..5c2ba1cbf3c5 100644
--- a/configure.in
+++ b/configure.in
@@ -3728,8 +3728,8 @@ if test "$_os" = "Darwin" && test "$with_system_python" != "no"; then
AC_MSG_RESULT([compiling against MacOSX10.4u.sdk (python version 2.3)])
PYTHON_CFLAGS="-I/Developer/SDKs/MacOSX10.4u.sdk/System/Library/Frameworks/Python.framework/Versions/2.3/include/python2.3"
PYTHON_LIBS="-framework Python"
-elif test -n "$with_system_python" -o -n "$with_system_libs" && \
- test "$with_system_python" != "no"; then
+elif test "$with_system_python" != "no" -o -n "$with_system_libs"; then
+ with_system_python=yes
AC_MSG_RESULT([external])
AM_PATH_PYTHON([2.2])
@@ -3738,7 +3738,7 @@ elif test -n "$with_system_python" -o -n "$with_system_libs" && \
PYTHON_CFLAGS="-I$python_include"
PYTHON_LIBS="-lpython$python_version"
fi
-if test "$with_system_python" != "no" ; then
+if test "$with_system_python" = "yes" ; then
SYSTEM_PYTHON=YES
dnl check if the headers really work:
save_CPPFLAGS="$CPPFLAGS"