summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorsb <sb@openoffice.org>2010-03-16 21:05:31 +0100
committersb <sb@openoffice.org>2010-03-16 21:05:31 +0100
commit6f92c8366367d8dd6de488d5479479374ae6e00f (patch)
tree37f0a61dd40df3f302e4a1943fd84d2f90a143b7 /configure.in
parentsb120: #i110061# ...and make sure CC/CXX are used where appropriate (again ba... (diff)
downloadcore-6f92c8366367d8dd6de488d5479479374ae6e00f.tar.gz
core-6f92c8366367d8dd6de488d5479479374ae6e00f.zip
sb120: #i106059# On Mac OS X, compile against system Python from 10.4 SDK (patch by cloph)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index bbff908599ad..97da96e3ecb6 100644
--- a/configure.in
+++ b/configure.in
@@ -3702,26 +3702,24 @@ AC_SUBST(LIBXML_LIBS)
dnl ===================================================================
dnl Check for system python
dnl ===================================================================
+AC_MSG_CHECKING([which python to use])
if test "$_os" = "Darwin" && test "$with_system_python" != "no"; then
with_system_python=yes
-fi
-AC_MSG_CHECKING([which python to use])
-if test -n "$with_system_python" -o -n "$with_system_libs" && \
+ AC_MSG_RESULT([compiling against MacOSX10.4u.sdk (python version 2.3)])
+ PYTHON_CFLAGS="-I/Developer/SDKs/MacOSX10.4u.sdk/System/Library/Frameworks/Python.framework/Versions/2.3/include/python2.3"
+ PYTHON_LIBS="-framework Python"
+elif test -n "$with_system_python" -o -n "$with_system_libs" && \
test "$with_system_python" != "no"; then
- SYSTEM_PYTHON=YES
AC_MSG_RESULT([external])
AM_PATH_PYTHON([2.2])
python_include=`$PYTHON -c "import distutils.sysconfig; print distutils.sysconfig.get_config_var('INCLUDEPY');"`
python_version=`$PYTHON -c "import distutils.sysconfig; print distutils.sysconfig.get_config_var('VERSION');"`
PYTHON_CFLAGS="-I$python_include"
-
- if test "$_os" = "Darwin"; then
- PYTHON_LIBS="-framework Python"
- else
- PYTHON_LIBS="-lpython$python_version"
- fi
-
+ PYTHON_LIBS="-lpython$python_version"
+fi
+if test "$with_system_python" != "no" ; then
+ SYSTEM_PYTHON=YES
dnl check if the headers really work:
save_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $PYTHON_CFLAGS"