summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorsb <sb@openoffice.org>2010-03-16 21:05:31 +0100
committersb <sb@openoffice.org>2010-03-16 21:05:31 +0100
commit084ef1d92ac0c8dd21d2a34cb10a2e1b26afcb1d (patch)
treea9042d6beed0e0ad8df2708adbee1a92412ad3cb /configure.in
parentsb120: #i110061# ...and make sure CC/CXX are used where appropriate (again ba... (diff)
downloadcore-084ef1d92ac0c8dd21d2a34cb10a2e1b26afcb1d.tar.gz
core-084ef1d92ac0c8dd21d2a34cb10a2e1b26afcb1d.zip
sb120: #i106059# On Mac OS X, compile against system Python from 10.4 SDK (patch by cloph)
(transplanted from 9f7ed09e2d7215d58bf71615b481b74b2344c79c)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 22982829a9a0..73c64175c2fc 100644
--- a/configure.in
+++ b/configure.in
@@ -3722,26 +3722,24 @@ AC_SUBST(LIBXML_LIBS)
dnl ===================================================================
dnl Check for system python
dnl ===================================================================
+AC_MSG_CHECKING([which python to use])
if test "$_os" = "Darwin" && test "$with_system_python" != "no"; then
with_system_python=yes
-fi
-AC_MSG_CHECKING([which python to use])
-if test -n "$with_system_python" -o -n "$with_system_libs" && \
+ AC_MSG_RESULT([compiling against MacOSX10.4u.sdk (python version 2.3)])
+ PYTHON_CFLAGS="-I/Developer/SDKs/MacOSX10.4u.sdk/System/Library/Frameworks/Python.framework/Versions/2.3/include/python2.3"
+ PYTHON_LIBS="-framework Python"
+elif test -n "$with_system_python" -o -n "$with_system_libs" && \
test "$with_system_python" != "no"; then
- SYSTEM_PYTHON=YES
AC_MSG_RESULT([external])
AM_PATH_PYTHON([2.2])
python_include=`$PYTHON -c "import distutils.sysconfig; print distutils.sysconfig.get_config_var('INCLUDEPY');"`
python_version=`$PYTHON -c "import distutils.sysconfig; print distutils.sysconfig.get_config_var('VERSION');"`
PYTHON_CFLAGS="-I$python_include"
-
- if test "$_os" = "Darwin"; then
- PYTHON_LIBS="-framework Python"
- else
- PYTHON_LIBS="-lpython$python_version"
- fi
-
+ PYTHON_LIBS="-lpython$python_version"
+fi
+if test "$with_system_python" != "no" ; then
+ SYSTEM_PYTHON=YES
dnl check if the headers really work:
save_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $PYTHON_CFLAGS"