summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRiccardo Magliocchetti <riccardo.magliocchetti@gmail.com>2012-08-30 19:30:14 +0200
committerRiccardo Magliocchetti <riccardo.magliocchetti@gmail.com>2012-08-30 19:30:14 +0200
commit69ae3fdde36606df21de594193dcd4776d329a07 (patch)
tree8842f41e6ea835a0ca5a8fff86a3b3a00d261322 /configure.in
parentLibreOffice installer does not use child projects (diff)
downloadcore-69ae3fdde36606df21de594193dcd4776d329a07.tar.gz
core-69ae3fdde36606df21de594193dcd4776d329a07.zip
configure: remove unneeded branch in bogus pkk-config check
The check for pkg-config is done only in mac os x and without mozilla. So a branch that checks for mozilla enable is never reached. While at it fix a couple of typos Change-Id: I910b2784426eba8978076ea5d1587a58e693a8b8
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 619a6ce8561f..764fdac08275 100644
--- a/configure.in
+++ b/configure.in
@@ -1093,7 +1093,7 @@ AC_ARG_ENABLE(liblangtag,
)
AC_ARG_ENABLE(bogus-pkg-config,
- AS_HELP_STRING([--enable-bogis-pkg-config],
+ AS_HELP_STRING([--enable-bogus-pkg-config],
[MACOSX only: on MacOSX pkg-config can cause trouble. by default if one is found in the PATH, an error is issued. This flag turn that error into a warning.]),
)
@@ -4434,15 +4434,10 @@ if test $_os = Darwin -a "$enable_mozilla" = no; then
if test "$PKG_CONFIG" = /usr/bin/pkg-config && ls -l /usr/bin/pkg-config | $GREP -q Mono.framework; then
AC_MSG_ERROR([yes, from Mono. This *will* break the build. Please remove or hide $PKG_CONFIG])
else
- if test "$enable_mozilla" = "yes"; then
- AC_MSG_RESULT([yes, from unkown origin])
- add_warning "Having a $PKG_CONFIG might have unexpected consequences, please consider hiding it"
+ if test "$enable_bogus_pkg_config" = "yes"; then
+ AC_MSG_RESULT([yes, user-approved from unknown origin.])
else
- if test "$enable_bogus_pkg_config" = "yes"; then
- AC_MSG_RESULT([yes, user-approved from unkown origin.])
- else
- AC_MSG_ERROR([yes, from unknown origin. This *will* break the build. Please remove or hide $PKG_CONFIG])
- fi
+ AC_MSG_ERROR([yes, from unknown origin. This *will* break the build. Please remove or hide $PKG_CONFIG])
fi
fi
else