summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2012-10-08 13:04:22 +0200
committerMichael Stahl <mstahl@redhat.com>2012-10-08 13:20:10 +0200
commit4c5589a397b05515ba4aec0c494f43fb9f750975 (patch)
treee432827a050c3a22c05700a271dd417e62ff4456 /configure.in
parentWaE: variable 'numusr' is uninitialized when used here (diff)
downloadcore-4c5589a397b05515ba4aec0c494f43fb9f750975.tar.gz
core-4c5589a397b05515ba4aec0c494f43fb9f750975.zip
configure: adjust beanshell/javascript options to
the changes in a72a7dc500ffd57662e8b9be61e4676266861c33. Change-Id: I79fba4dbe8a72b65625a9ed11fa0b3cebdf80426
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 22 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index cc8524f99d9a..3c324811ec8b 100644
--- a/configure.in
+++ b/configure.in
@@ -637,12 +637,14 @@ AC_ARG_ENABLE(ext-report-builder,
AC_ARG_ENABLE(ext-scripting-beanshell,
AS_HELP_STRING([--enable-ext-scripting-beanshell],
- [Enable support for scripts in BeanShell.])
+ [DEPRECATED: use --enable-scripting-beanshell instead.])
+,AC_MSG_ERROR([--enable-ext-scripting-beanshell is no longer supported.])
)
AC_ARG_ENABLE(ext-scripting-javascript,
AS_HELP_STRING([--enable-ext-scripting-javascript],
- [Enable support for scripts in JavaScript.])
+ [DEPRECATED: use --enable-scripting-javascript instead.])
+,AC_MSG_ERROR([--enable-ext-scripting-javascript is no longer supported.])
)
AC_ARG_ENABLE(ext-typo,
@@ -1455,6 +1457,12 @@ AC_ARG_WITH(hsqldb-jar,
[Specify path to jarfile manually.]),
HSQLDB_JAR=$withval)
+AC_ARG_ENABLE(scripting-beanshell,
+ AS_HELP_STRING([--disable-scripting-beanshell],
+ [Disable support for scripts in BeanShell.]),
+,
+)
+
AC_ARG_WITH(system-beanshell,
AS_HELP_STRING([--with-system-beanshell],
[Use beanshell already on system.]),,
@@ -1465,6 +1473,12 @@ AC_ARG_WITH(beanshell-jar,
[Specify path to jarfile manually.]),
BSH_JAR=$withval)
+AC_ARG_ENABLE(scripting-javascript,
+ AS_HELP_STRING([--disable-scripting-javascript],
+ [Disable support for scripts in JavaScript.]),
+,
+)
+
AC_ARG_WITH(system-rhino,
AS_HELP_STRING([--with-system-rhino],
[Use rhino already on system.]),,)
@@ -10176,9 +10190,9 @@ AC_SUBST(COMMONS_HTTPCLIENT_JAR)
AC_SUBST(COMMONS_LOGGING_JAR)
AC_SUBST(TOMCAT_TARBALL)
-# scripting provider for BeanShell extension?
-AC_MSG_CHECKING([whether to build extension for support of scripts in BeanShell])
-if test "x$enable_ext_scripting_beanshell" = "xyes" -a "x$enable_extension_integration" != "xno" -a "x$with_java" != "xno"; then
+# scripting provider for BeanShell?
+AC_MSG_CHECKING([whether to build support for scripts in BeanShell])
+if test "${enable_scripting_beanshell}" != "no" -a "x$with_java" != "xno"; then
AC_MSG_RESULT([yes])
ENABLE_SCRIPTING_BEANSHELL=YES
@@ -10210,9 +10224,9 @@ AC_SUBST(SYSTEM_BSH)
AC_SUBST(BSH_JAR)
AC_SUBST(BSH_TARBALL)
-# scripting provider for JavaScript extension?
-AC_MSG_CHECKING([whether to build extension for support of scripts in JavaScript])
-if test "x$enable_ext_scripting_javascript" = "xyes" -a "x$enable_extension_integration" != "xno" -a "x$with_java" != "xno"; then
+# scripting provider for JavaScript?
+AC_MSG_CHECKING([whether to build support for scripts in JavaScript])
+if test "${enable_scripting_javascript}" != "no" -a "x$with_java" != "xno"; then
AC_MSG_RESULT([yes])
ENABLE_SCRIPTING_JAVASCRIPT=YES