summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-02-17 09:47:37 +0100
committerDavid Tardon <dtardon@redhat.com>2012-02-17 15:53:56 +0100
commite1462d24f47c56cc5e4d8cbec09fb755ce4b08fe (patch)
treeee0a04368a814db62d5521dfb3b0cd42c6f8aefa /configure.in
parentallow using system libxml in cross-compilation build (diff)
downloadcore-e1462d24f47c56cc5e4d8cbec09fb755ce4b08fe.tar.gz
core-e1462d24f47c56cc5e4d8cbec09fb755ce4b08fe.zip
allow using system cppunit in cross-compilation build
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 56cbbce43976..b3c2258b2e22 100644
--- a/configure.in
+++ b/configure.in
@@ -1933,6 +1933,10 @@ dnl ===================================================================
dnl options for stuff used during cross-compilation build
dnl ===================================================================
+AC_ARG_WITH(system-cppunit-for-build,
+ AS_HELP_STRING([--with-system-cppunit-for-build],
+ [Use cppunit/libxslt already on system for build tools (cross-compilation only).]))
+
AC_ARG_WITH(system-libxml-for-build,
AS_HELP_STRING([--with-system-libxml-for-build],
[Use libxml/libxslt already on system for build tools (cross-compilation only).]))
@@ -3160,6 +3164,7 @@ if test "$cross_compiling" = "yes"; then
unset CC CXX SYSBASE CFLAGS
unset PYTHON_CFLAGS PYTHON_LIBS
unset AR NM OBJDUMP PKG_CONFIG RANLIB STRIP
+ unset CPPUNIT_CFLAGS CPPUNIT_LIBS
unset LIBXML_CFLAGS LIBXML_LIBS LIBXSLT_CFLAGS LIBXSLT_LIBS XSLTPROC
test -n "$CC_FOR_BUILD" && export CC="$CC_FOR_BUILD"
test -n "$CXX_FOR_BUILD" && export CXX="$CXX_FOR_BUILD"
@@ -3170,6 +3175,7 @@ if test "$cross_compiling" = "yes"; then
test $with_java = no && sub_conf_opts="$sub_conf_opts --without-java"
test $with_junit = no && sub_conf_opts="$sub_conf_opts --without-junit"
test -n "$TARFILE_LOCATION" && sub_conf_opts="$sub_conf_opts --with-external-tar=$TARFILE_LOCATION"
+ test -n "$with_system_cppunit_for_build" && sub_conf_opts="$sub_conf_opts --with-system-cppunit"
test -n "$with_system_libxml_for_build" && sub_conf_opts="$sub_conf_opts --with-system-libxml"
./configure \
--disable-mozilla \