summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-02-17 09:51:08 +0100
committerDavid Tardon <dtardon@redhat.com>2012-02-17 15:53:58 +0100
commitb60aedc17c12db865f5994a579facb10a3e9343e (patch)
tree9a53310d1dc0a15febee069937148813f2fb9dc9 /configure.in
parentallow using system db in cross-compilation build (diff)
downloadcore-b60aedc17c12db865f5994a579facb10a3e9343e.tar.gz
core-b60aedc17c12db865f5994a579facb10a3e9343e.zip
allow using system expat in cross-compilation build
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bbb36e276c48..110c1b2364ba 100644
--- a/configure.in
+++ b/configure.in
@@ -1945,6 +1945,10 @@ AC_ARG_WITH(system-db-for-build,
AS_HELP_STRING([--with-system-db-for-build],
[Use db/libxslt already on system for build tools (cross-compilation only).]))
+AC_ARG_WITH(system-expat-for-build,
+ AS_HELP_STRING([--with-system-expat-for-build],
+ [Use expat/libxslt already on system for build tools (cross-compilation only).]))
+
AC_ARG_WITH(system-libxml-for-build,
AS_HELP_STRING([--with-system-libxml-for-build],
[Use libxml/libxslt already on system for build tools (cross-compilation only).]))
@@ -3186,6 +3190,7 @@ if test "$cross_compiling" = "yes"; then
test -n "$with_system_boost_for_build" && sub_conf_opts="$sub_conf_opts --with-system-boost"
test -n "$with_system_cppunit_for_build" && sub_conf_opts="$sub_conf_opts --with-system-cppunit"
test -n "$with_system_db_for_build" && sub_conf_opts="$sub_conf_opts --with-system-db"
+ test -n "$with_system_expat_for_build" && sub_conf_opts="$sub_conf_opts --with-system-expat"
test -n "$with_system_libxml_for_build" && sub_conf_opts="$sub_conf_opts --with-system-libxml"
./configure \
--disable-mozilla \