summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2012-02-27 17:02:59 +0200
committerTor Lillqvist <tml@iki.fi>2012-02-27 17:02:59 +0200
commit651dcc29f413b6bb95e01c90d4113ff7a10db3be (patch)
treefd6147905c52273cd55859c875571970138ebe22 /configure.in
parents/interpreters/scripting/ (diff)
downloadcore-651dcc29f413b6bb95e01c90d4113ff7a10db3be.tar.gz
core-651dcc29f413b6bb95e01c90d4113ff7a10db3be.zip
Add --disable-extensions switch for future implementation
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 914e8cf47bd8..86db7689270f 100644
--- a/configure.in
+++ b/configure.in
@@ -393,6 +393,11 @@ AC_ARG_ENABLE(database-connectivity,
[Disable various database connectivity. Work in progress, use only if you are hacking on it.])
)
+AC_ARG_ENABLE(extensions,
+ AS_HELP_STRING([--disable-extensions],
+ [Disable all add-on extension functionality. Work in progress, use only if you are hacking on it.])
+)
+
AC_ARG_ENABLE(scripting,
AS_HELP_STRING([--disable-scripting],
[Disable BASIC, Java and Python. Work in progress, use only if you are hacking on it.])
@@ -2042,6 +2047,22 @@ else
fi
AC_SUBST(DISABLE_DBCONNECTIVITY)
+if test -z "$enable_extensions"; then
+ # For iOS disable extensions unless specifically overridden with
+ # --enable-extensions.
+ if test $_os != iOS; then
+ enable_extensions=yes
+ fi
+fi
+
+DISABLE_EXTENSIONS=''
+if test "$enable_extensions" = yes; then
+ BUILD_TYPE="$BUILD_TYPE EXTENSIONS"
+else
+ DISABLE_EXTENSIONS='TRUE'
+fi
+AC_SUBST(DISABLE_EXTENSIONS)
+
if test -z "$enable_scripting"; then
# Disable scripting for iOS unless specifically overridden
# with --enable-scripting.