summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2012-02-24 13:24:01 +0100
committerLuboš Luňák <l.lunak@suse.cz>2012-02-24 14:06:19 +0100
commit1cf7ab61a71d4b7295942ff5c855896e60c15081 (patch)
tree92e95f0d8d9caba44315e8eea1fed257addd89bd /configure.in
parentremove unused parameter EVAL (diff)
downloadcore-1cf7ab61a71d4b7295942ff5c855896e60c15081.tar.gz
core-1cf7ab61a71d4b7295942ff5c855896e60c15081.zip
use -std=gnu++0x rather than -std=c++0x
The gcc default for C++ is -std=gnu++98, and -std=c++98 is used explicitly or with -ansi, so the C++0x "default" should be gnu++0x.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index cefc6e82076c..9c244096a20f 100644
--- a/configure.in
+++ b/configure.in
@@ -4333,9 +4333,9 @@ if test "$GCC" = "yes"; then
AC_MSG_RESULT([no])
fi
- AC_MSG_CHECKING([whether $CC supports -std=c++0x without Language Defect 757])
+ AC_MSG_CHECKING([whether $CC supports -std=gnu++0x without Language Defect 757])
save_CXXFLAGS=$CXXFLAGS
- CXXFLAGS="$CXXFLAGS -std=c++0x"
+ CXXFLAGS="$CXXFLAGS -std=gnu++0x"
AC_LANG_PUSH([C++])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
@@ -6702,7 +6702,7 @@ if test "$with_system_mdds" = "yes"; then
dnl ===================================================================
AC_MSG_CHECKING([which hash container mdds shall use])
if test "x$HAVE_CXX0X" = "xTRUE"; then
- MDDS_CPPFLAGS="-std=c++0x"
+ MDDS_CPPFLAGS="-std=gnu++0x"
AC_MSG_RESULT([std::unordered_map])
else
MDDS_CPPFLAGS="-DMDDS_HASH_CONTAINER_BOOST"