summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2012-08-31 15:43:46 +0200
committerPetr Mladek <pmladek@suse.cz>2012-08-31 15:52:21 +0200
commit4b27695fea841d54f7f6407b873bbd33709eeab5 (patch)
treec68d22e7838eec4fa536b863e9306d6738e41f6c /configure.in
parenthandle missing cond format entries more gracefully, related fdo#52340 (diff)
downloadcore-4b27695fea841d54f7f6407b873bbd33709eeab5.tar.gz
core-4b27695fea841d54f7f6407b873bbd33709eeab5.zip
add "Tango Testing" icon theme
It is enabled by default for dev build. It will be used for reworking the Tango theme by the design team. The them was requested by Stefan Knorr (Astron) <heinzlesspam at gmail dot com> The two intial icons are from Alexander Wilms <alexander dot wilms at zoho dot com> Change-Id: I9205a3164352442a2cdc02e75e58b15b327dfbd3
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 16 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index e14fb662877d..4e87f1a28697 100644
--- a/configure.in
+++ b/configure.in
@@ -1153,7 +1153,7 @@ AC_ARG_WITH(vba-package-format,
AC_ARG_WITH(theme,
AS_HELP_STRING([--with-theme="theme1 theme2..."],
[Choose which themes to include. By default those themes with an '*' are included.
- Possible choices: *crystal, *default (galaxy), *hicontrast, human, industrial, *oxygen, *tango.]),
+ Possible choices: *crystal, *default (galaxy), *hicontrast, human, industrial, *oxygen, *tango, *tango_testing.]),
,)
AC_ARG_WITH(helppack-integration,
@@ -2075,6 +2075,19 @@ AC_ARG_WITH(check-jobs,
,)
dnl ===================================================================
+dnl Test whether build target is Release Build
+dnl ===================================================================
+AC_MSG_CHECKING([whether build target is Release Build])
+if test "$enable_release_build" = "" -o "$enable_release_build" = "no"; then
+ AC_MSG_RESULT([no])
+ ENABLE_RELEASE_BUILD="FALSE"
+else
+ AC_MSG_RESULT([yes])
+ ENABLE_RELEASE_BUILD="TRUE"
+fi
+AC_SUBST(ENABLE_RELEASE_BUILD)
+
+dnl ===================================================================
dnl MacOSX build and runtime environment options
dnl ===================================================================
@@ -10396,12 +10409,13 @@ AC_MSG_CHECKING([which themes to include])
# if none given use default subset of available themes
if test "x$with_theme" = "x" -o "x$with_theme" = "xyes"; then
with_theme="crystal default hicontrast oxygen tango"
+ test "$ENABLE_RELEASE_BUILD" = "FALSE" && with_theme="$with_theme tango_testing"
fi
WITH_THEMES=""
for theme in $with_theme; do
case $theme in
- crystal|default|galaxy|hicontrast|human|industrial|oxygen|tango) : ;;
+ crystal|default|galaxy|hicontrast|human|industrial|oxygen|tango|tango_testing) : ;;
*) AC_MSG_ERROR([Unknown value for --with-theme: $theme]) ;;
esac
WITH_THEMES="$WITH_THEMES $theme"
@@ -10863,19 +10877,6 @@ fi
AC_SUBST(ENABLE_ONLINE_UPDATE)
dnl ===================================================================
-dnl Test whether build target is Release Build
-dnl ===================================================================
-AC_MSG_CHECKING([whether build target is Release Build])
-if test "$enable_release_build" = "" -o "$enable_release_build" = "no"; then
- AC_MSG_RESULT([no])
- ENABLE_RELEASE_BUILD="FALSE"
-else
- AC_MSG_RESULT([yes])
- ENABLE_RELEASE_BUILD="TRUE"
-fi
-AC_SUBST(ENABLE_RELEASE_BUILD)
-
-dnl ===================================================================
dnl Test whether to create MSI with LIMITUI=1 (silent install)
dnl ===================================================================
AC_MSG_CHECKING([whether to create MSI with LIMITUI=1 (silent install)])