summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2011-12-11 00:08:39 +0200
committerTor Lillqvist <tlillqvist@suse.com>2011-12-11 00:14:47 +0200
commit75aacd87bbbddb860efb57f046c84e4f107a8839 (patch)
tree673eb3300eecd81148cef2461ff5a853b75869ab /configure.in
parentuse PACKAGEVERSION as the base of MSI ProductVersion (diff)
downloadcore-75aacd87bbbddb860efb57f046c84e4f107a8839.tar.gz
core-75aacd87bbbddb860efb57f046c84e4f107a8839.zip
Download and build FreeType and fontconfig for Android
It will probably be simplest to just use FreeType on Android, too. (Android uses it itself, but doesn't provide its API publicly.) Probably fontconfig, too, although there shouldn't be much configuration per se that a LibreOffice-baed app would have to do at run-time; it will have to bundle all fonts it is going to use anyway, I think, so all font information is known a priori. But maybe in the future there will be user-installable system fonts on Android, or something.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0228af5ae058..71b644ff230e 100644
--- a/configure.in
+++ b/configure.in
@@ -263,6 +263,10 @@ linux-androideabi*)
AC_MSG_ERROR([You need to set the $var environment variable in a cross-compilation for Android. See README.cross for an example.])
fi
done
+
+ BUILD_TYPE="$BUILD_TYPE FONTCONFIG FREETYPE"
+ FREETYPE_TARBALL=dbf2caca1d3afd410a29217a9809d397-freetype-2.4.8.tar.bz2
+ FONTCONFIG_TARBALL=77e15a92006ddc2adbb06f840d591c0e-fontconfig-2.8.0.tar.gz
;;
*)
@@ -282,6 +286,8 @@ AC_SUBST(OSVERSION)
AC_SUBST(PTHREAD_CFLAGS)
AC_SUBST(PTHREAD_LIBS)
+AC_SUBST(FREETYPE_TARBALL)
+AC_SUBST(FONTCONFIG_TARBALL)
###############################################################################
# Extensions switches --enable/--disable