summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEike Rathke <erack@redhat.com>2012-04-02 22:24:00 +0200
committerEike Rathke <erack@redhat.com>2012-04-03 00:15:30 +0200
commit43084e8b30c101a44510b7a8267d5c2b316a17bb (patch)
treeea6810804a963c35683c5e16cf0fe02f1d15d0bf /configure.in
parentConvert tools/table.hxx to std::set in EditorWindow class in basctl module (diff)
downloadcore-43084e8b30c101a44510b7a8267d5c2b316a17bb.tar.gz
core-43084e8b30c101a44510b7a8267d5c2b316a17bb.zip
only as of ICU 4.9 RBBI the Prepend property is empty
This reverts 0c08a84c04b166ab6479716e2c33cd444d7e3dbe and instead strips the Prepend variable during build time.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0100f97d3408..067fa4f57b1f 100644
--- a/configure.in
+++ b/configure.in
@@ -7487,6 +7487,7 @@ ICU_MAJOR=
ICU_MINOR=
ICU_MICRO=
ICU_RECLASSIFIED_CLOSE_PARENTHESIS=
+ICU_RECLASSIFIED_PREPEND_SET_EMPTY=
AC_MSG_CHECKING([which icu to use])
if test "$with_system_icu" = "yes"; then
AC_MSG_RESULT([external])
@@ -7549,6 +7550,9 @@ You can use --with-system-icu-for-build=force to use it anyway.])
if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "4"; then
ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
fi
+ if test "$ICU_MAJOR" -ge "5" -o "$ICU_MAJOR" = "4" -a "$ICU_MINOR" -ge "9"; then
+ ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
+ fi
fi
libo_MINGW_CHECK_DLL([ICUDATA], [icudata][$ICU_MAJOR][$ICU_MINOR])
@@ -7558,6 +7562,7 @@ else
AC_MSG_RESULT([internal])
SYSTEM_ICU="NO"
ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
+ # ICU_RECLASSIFIED_PREPEND_SET_EMPTY not applied for our internal ICU 4.4.2
BUILD_TYPE="$BUILD_TYPE ICU"
fi
@@ -7569,6 +7574,7 @@ AC_SUBST(ICU_MAJOR)
AC_SUBST(ICU_MINOR)
AC_SUBST(ICU_MICRO)
AC_SUBST(ICU_RECLASSIFIED_CLOSE_PARENTHESIS)
+AC_SUBST(ICU_RECLASSIFIED_PREPEND_SET_EMPTY)
AC_SUBST([MINGW_ICUDATA_DLL])
AC_SUBST([MINGW_ICUI18N_DLL])
AC_SUBST([MINGW_ICUUC_DLL])