summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2012-10-03 16:05:51 +0200
committerRene Engelhard <rene@debian.org>2012-10-03 17:10:27 +0200
commit9ed34f8137e1ec4f58151eba74507102192cb8fd (patch)
tree71f222a84595eace3a0a2240d6c7f227e4e29e91 /configure.in
parentfdo#50936 fix link to license file in SDK documentation (diff)
downloadcore-9ed34f8137e1ec4f58151eba74507102192cb8fd.tar.gz
core-9ed34f8137e1ec4f58151eba74507102192cb8fd.zip
fix POPPLER_NOT_0_20_0 check
0.20x is affected, not only 0.20. I think this should be checked here only, though if it was 100% sure a poppler bug. But this is at least better to the broken check before.. Change-Id: If01a4329d18d317371be11d63c66b3487f5f556b
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 45c3d85ef9c0..f8ccb943876d 100644
--- a/configure.in
+++ b/configure.in
@@ -9704,8 +9704,8 @@ if test "x$enable_ext_pdfimport" != "xno" -a "x$enable_extension_integration" !=
SYSTEM_POPPLER=YES
PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
# sdext test fails with 0.20.0
- PKG_CHECK_MODULES( POPPLER_NOT_0_20_0, poppler != 0.20.0,
- , [AC_MSG_ERROR([Poppler 0.20.0 is broken, do not use --with-system-poppler or use a different version])])
+ PKG_CHECK_MODULES( POPPLER_NOT_0_20_0, poppler < 0.20.0,
+ , [AC_MSG_ERROR([Poppler 0.20.x is broken, do not use --with-system-poppler or use a different version])])
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
save_CPPFLAGS=$CPPFLAGS