summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBernhard Rosenkraenzer <bero@arklinux.org>2010-11-01 17:34:28 +0100
committerPetr Mladek <pmladek@suse.cz>2010-11-01 17:36:17 +0100
commit7fb5897aa046677e65bbe143390a63707d5a319d (patch)
treedda9bbac42956056793fe71dead0015573f9f3ee /configure.in
parentMerge branch 'master' of ssh://git.freedesktop.org/git/libreoffice/bootstrap (diff)
downloadcore-7fb5897aa046677e65bbe143390a63707d5a319d.tar.gz
core-7fb5897aa046677e65bbe143390a63707d5a319d.zip
correctly check Template Pack and Lightproof with --with-lang=ALL
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7a9dc4317e88..396aaf4fbd3e 100644
--- a/configure.in
+++ b/configure.in
@@ -6999,7 +6999,7 @@ else
LIGHTPROOF_LANG=
# check whether the langs are requested at all
for lang in $wanted_lightproof ; do
- if test -n "`echo $with_lang | grep "$lang"`" ; then
+ if test "$with_lang" = "ALL" -o -n "`echo $with_lang | grep "$lang"`" ; then
LIGHTPROOF_LANG="$LIGHTPROOF_LANG $lang"
fi
done
@@ -7173,7 +7173,7 @@ else
SUNTEMPLATES_LANG=
# check whether the langs are requested at all
for lang in $wanted_sun_templates ; do
- if test -n "`echo $with_lang | grep "$lang"`" ; then
+ if test "$with_lang" = "ALL" -o -n "`echo $with_lang | grep "$lang"`" ; then
SUNTEMPLATES_LANG="$SUNTEMPLATES_LANG $lang"
fi
done