summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2012-01-18 15:34:39 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2012-02-05 19:34:01 -0600
commit63fd78954dfa1a47331523a1296409cb46de6e55 (patch)
tree23825979e536a94b7c4867765afbb0a165c27fb2 /configure.in
parentexport a flag-variable to deal with cygwin only export (diff)
downloadcore-63fd78954dfa1a47331523a1296409cb46de6e55.tar.gz
core-63fd78954dfa1a47331523a1296409cb46de6e55.zip
add api in configure.in to deal with PATH manipulations...
prep-work for the migration of PATH handling from set_soenv...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a151780f5f7b..f6cd82577f5f 100644
--- a/configure.in
+++ b/configure.in
@@ -1934,6 +1934,18 @@ dnl ===================================================================
dnl check for required programs (grep, awk, sed, bash)
dnl ===================================================================
AC_PROG_EGREP
+
+pathmunge ()
+{
+ if ! echo HOST_PATH | $EGREP -q "(^|:)$1($|:)" ; then
+ if test "$2" = "after" ; then
+ HOST_PATH="$HOST_PATH:$1"
+ else
+ HOST_PATH="$1:$HOST_PATH"
+ fi
+ fi
+}
+
AC_PROG_AWK
AC_PATH_PROG( AWK, $AWK)
if test -z "$AWK"; then