summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorLionel Elie Mamane <lionel@mamane.lu>2012-02-02 15:47:12 +0100
committerLionel Elie Mamane <lionel@mamane.lu>2012-02-02 15:48:26 +0100
commit0c064e0303ed5e28888f4961cc590f62bcb2151b (patch)
tree6c28c2ad9c18db8c8734a16f2981595eaa965a11 /configure.in
parentfdo#45446: officecfg: turn off SaveBackwardCompatibleODF (diff)
downloadcore-0c064e0303ed5e28888f4961cc590f62bcb2151b.tar.gz
core-0c064e0303ed5e28888f4961cc590f62bcb2151b.zip
postgresql: enable Kerberos&GSSAPI on GNU/Linux and *BSD
It is part of the default/core install of (the major distributions of) these OSs
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a1b2c09e634d..9335fddcf0a1 100644
--- a/configure.in
+++ b/configure.in
@@ -1669,10 +1669,6 @@ AC_ARG_WITH(krb5,
By default automatically enabled on platforms
where a good system Kerberos 5 is available.]),
,)
-#AC_ARG_WITH(system-redland,
-# AS_HELP_STRING([--with-system-redland],
-# [Use redland library already on system.]),,
-# [with_system_redland="$with_system_libs"])
AC_ARG_WITH(gssapi,
AS_HELP_STRING([--with-gssapi],
@@ -6153,6 +6149,19 @@ if test "x$enable_postgresql_sdbc" != "xno"; then
AC_MSG_ERROR([Refusing to enable MIT Kerberos 5 or GSSAPI on Microsoft Windows.])
fi
;;
+ Linux|GNU|*BSD)
+ if test "$with_krb5" != "no"; then
+ WITH_KRB5=YES
+ AC_SEARCH_LIBS(com_err, [krb5 'krb5 -lcrypto -ldes -lasn1 -lroken' com_err 'com_err -lssl -lcrypto'], [],
+ [AC_MSG_ERROR([could not find function 'com_err' required for Kerberos 5])])
+ AC_SEARCH_LIBS(krb5_sendauth, [krb5 'krb5 -lcrypto -ldes -lasn1 -lroken'], [],
+ [AC_MSG_ERROR([could not find function 'krb5_sendauth' required for Kerberos 5])])
+ fi
+ if test "$with_gssapi" != "no"; then
+ WITH_GSSAPI=YES
+ AC_SEARCH_LIBS(gss_init_sec_context, [gssapi_krb5 gss 'gssapi -lkrb5 -lcrypto'], [],
+ [AC_MSG_ERROR([could not find function 'gss_init_sec_context' required for GSSAPI])])
+ fi
*)
if test "$with_krb5" = "yes"; then
WITH_KRB5=YES