summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobert Nagy <robert@openbsd.org>2010-11-04 00:43:13 +0100
committerRene Engelhard <rene@debian.org>2010-11-04 00:43:13 +0100
commit03e2863a1abcaa29c4f046b11a4466788311ffc4 (patch)
tree8c33f2192575ed32c6cd9f96d34b3210aa04c0c3 /configure.in
parentuse versioned path in download tarballs (fdo#30837) (diff)
downloadcore-03e2863a1abcaa29c4f046b11a4466788311ffc4.tar.gz
core-03e2863a1abcaa29c4f046b11a4466788311ffc4.zip
make LibreOffice boostrap on OpenBSD
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 19 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 52d7c8feec8f..94c1ba8ef687 100644
--- a/configure.in
+++ b/configure.in
@@ -1556,9 +1556,21 @@ case "$build_os" in
test_cups=no
test_randr=no
test_freetype=yes
- PTHREAD_LIBS=-pthread
+ PTHREAD_LIBS=-pthread
_os=AIX
;;
+ openbsd*)
+ test_x=yes
+ test_gtk=yes
+ build_cairo=yes
+ test_kde=yes
+ test_cups=yes
+ test_freetype=yes
+ test_randr=yes
+ PTHREAD_CFLAGS="-pthread -D_THREAD_SAFE"
+ PTHREAD_LIBS="-pthread"
+ _os=OpenBSD
+ ;;
*)
AC_MSG_ERROR([$_os operating system is not suitable to build LibreOffice!])
;;
@@ -3803,6 +3815,9 @@ if test "$enable_epm" = "yes"; then
AIX)
PKGFORMAT=rpm
;;
+ OpenBSD)
+ PKGFORMAT=portable
+ ;;
*BSD)
PKGFORMAT=bsd
;;
@@ -5549,7 +5564,7 @@ fi
dnl ===================================================================
dnl Check for system openssl
dnl ===================================================================
-if test "$_os" = "Darwin" -o "$_os" = "NetBSD" && test "$with_system_openssl" != "no"; then
+if test "$_os" = "Darwin" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" && test "$with_system_openssl" != "no"; then
with_system_openssl=yes
fi
AC_MSG_CHECKING([which libssl to use])
@@ -5558,7 +5573,7 @@ if test -n "$with_system_openssl" -o -n "$with_system_libs" && \
AC_MSG_RESULT([external])
# Mac OS builds should get out without extra stuff is the Mac porters'
# wish. And pkg-config is although Xcode ships a .pc for openssl
- if test "$_os" = "Darwin" -o "$_os" = "NetBSD" ; then
+ if test "$_os" = "Darwin" -o "$_os" = "NetBSD" -o "$_os" = "OpenBSD" ; then
OPENSSL_CFLAGS=
OPENSSL_LIBS="-lssl -lcrypto"
else
@@ -7833,7 +7848,7 @@ dnl ===================================================================
dnl Number of CPUs to use during the build
dnl ===================================================================
AC_MSG_CHECKING([for number of processors to use])
-if test "z`uname -s`" = "zDarwin"; then
+if test "z`uname -s`" = "zDarwin" -o "z`uname -s`" = "zOpenBSD"; then
BUILD_NCPUS=`sysctl -n hw.ncpu`
else
BUILD_NCPUS=`grep $'^processor\t*:' /proc/cpuinfo | wc -l`