summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@verizon.net>2012-08-22 21:51:31 -0400
committerDavid Tardon <dtardon@redhat.com>2012-10-07 10:42:09 +0200
commit5d0c35242bb24605ca9ce6f45806b8997a17799b (patch)
treecba88cec6863d25b3071c1c042d3aede444f6785 /configure.in
parentfix python build with VC2012 (diff)
downloadcore-5d0c35242bb24605ca9ce6f45806b8997a17799b.tar.gz
core-5d0c35242bb24605ca9ce6f45806b8997a17799b.zip
fix cli_ure build with Win8 SDK
Change-Id: I4842d848234a5dc21085a3fd0aa0a79c58c71e8c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1655e2d32a44..6249f8c60780 100644
--- a/configure.in
+++ b/configure.in
@@ -4700,6 +4700,38 @@ if test "$build_os" = "cygwin"; then
CSC_PATH=`cygpath -d "$CSC_PATH"`
CSC_PATH=`cygpath -u "$CSC_PATH"`
+ dnl Check al.exe
+ AC_PATH_PROG(AL_PATH, al.exe)
+ if test -n "$AL_PATH";then
+ AL_PATH=`dirname "$AL_PATH"`
+ fi
+ if test -n "$with_al_path";then
+ with_al_path=`cygpath -u "$with_al_path"`
+ fi
+ if test -x "$with_al_path/al.exe"; then
+ AL_PATH="$with_al_path"
+ fi
+ if test -z "$AL_PATH"; then
+ winsdktest=`./oowintool --windows-sdk-home`
+ if test -x "$winsdktest/Bin/al.exe"; then
+ AL_PATH="$winsdktest/Bin"
+ fi
+ fi
+ if test -z "$AL_PATH"; then
+ altest=`./oowintool --al-home`
+ if test -x "$altest/bin/al.exe"; then
+ AL_PATH="$altest/bin"
+ elif test -x "$altest/al.exe"; then
+ AL_PATH="$altest"
+ fi
+ fi
+ if test ! -x "$AL_PATH/al.exe"; then
+ AC_MSG_ERROR([al.exe not found. Make sure it's in PATH or use --with-al-path])
+ fi
+ # Convert to posix path with 8.3 filename restrictions ( No spaces )
+ AL_PATH=`cygpath -d "$AL_PATH"`
+ AL_PATH=`cygpath -u "$AL_PATH"`
+
dnl Check mscoree.lib / .NET Framework dir
AC_MSG_CHECKING(.NET Framework)
if test -n "$with_dotnet_framework_home"; then
@@ -4726,6 +4758,9 @@ if test "$build_os" = "cygwin"; then
PathFormat "$MIDL_PATH"
MIDL_PATH="$formatted_path"
+
+ PathFormat "$AL_PATH"
+ AL_PATH="$formatted_path"
PathFormat "$DOTNET_FRAMEWORK_HOME"
DOTNET_FRAMEWORK_HOME="$formatted_path"
@@ -12680,6 +12715,7 @@ else
pathmunge "$WINDOWS_SDK_HOME/bin" "before"
pathmunge "$CSC_PATH" "before"
pathmunge "$MIDL_PATH" "before"
+ pathmunge "$AL_PATH" "before"
pathmunge "$MSPDB_PATH" "before"
if test "$BITNESS_OVERRIDE" = 64; then
pathmunge "$COMPATH/bin/amd64" "before"