summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2011-10-20 16:36:58 +0200
committerStephan Bergmann <sbergman@redhat.com>2011-10-20 23:04:12 +0200
commitfc98a971350bed06e75443d89cef41d6bd346f7c (patch)
tree668505274f9c5e596e173a513bd0aaab392cc97b /configure.in
parentReport failing Unixlink processing. (diff)
downloadcore-fc98a971350bed06e75443d89cef41d6bd346f7c.tar.gz
core-fc98a971350bed06e75443d89cef41d6bd346f7c.zip
Introduced --disable-linkoo.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 603745290f77..df644ae09a05 100644
--- a/configure.in
+++ b/configure.in
@@ -257,6 +257,10 @@ AC_ARG_ENABLE(dbgutil,
[Include additional debugging utilities, such as assertions, object
counting, etc. Larger build. Independent from --enable-debug]))
+AC_ARG_ENABLE(linkoo,
+ AS_HELP_STRING([--disable-linkoo],
+ [Disable linkoo for the smoketest installation.]))
+
AC_ARG_ENABLE(lto,
AS_HELP_STRING([--enable-lto],
[Enable link-time optimization. Suitable for product builds.
@@ -2336,6 +2340,18 @@ fi
AC_SUBST(PRODUCT)
AC_SUBST(PROEXT)
+dnl Determine whether to use linkoo for the smoketest installation
+dnl ===================================================================
+AC_MSG_CHECKING([whether to use linkoo for the smoketest installation])
+if test "$enable_linkoo" = "no"; then
+ DISABLE_LINKOO="TRUE"
+ AC_MSG_RESULT([no])
+else
+ DISABLE_LINKOO=
+ AC_MSG_RESULT([yes])
+fi
+AC_SUBST(DISABLE_LINKOO)
+
# Set the ENABLE_LTO variable
# ===================================================================
AC_MSG_CHECKING([whether to use link-time optimization])