summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2011-11-16 06:12:09 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2011-11-16 06:18:53 -0600
commitcb70868bdae30e01323afeb7cc6021a6b10003f0 (patch)
treea10ca5ca10df21f30246f61a2326275f7f58af70 /configure.in
parentadd a semaphore-file to allow for location of the root of the core repo (diff)
downloadcore-cb70868bdae30e01323afeb7cc6021a6b10003f0.tar.gz
core-cb70868bdae30e01323afeb7cc6021a6b10003f0.zip
add utility script and build_env to avoid sourcing Env.Host.sh
The goal is to able to do partial build without having to source Env.Host.sh into one's environment There is 2 way to use this: 1/ copy the scripts lo_find_src_root and lo_proxy_start somewhere in your PATH, and then you can add alias build='lo_proxy_start build' alias deliver='lo_proxy_start deliver' in your .bashrc at that point you can use build and deliver anywhere in the source tree without the need to source anything. This allow you to switch from one source tree to another. the proper SRC_ROOT will be determined automatically based on the current working directory 2/ source build_env build_env only source the bare minimum to allow build and make to work for the associated source tree. If you want to work in a diffrent tree, you need to resource
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 19beb9ae6c8b..17df05396acc 100644
--- a/configure.in
+++ b/configure.in
@@ -40,9 +40,14 @@ AC_SUBST(CROSS_COMPILING)
if test "$build_os" = "cygwin"; then
EXEEXT_FOR_BUILD=.exe
+ SRC_ROOT=`pwd`
+ SRC_ROOT=`cygpath -d "$SRC_ROOT"`
+ SRC_ROOT=`cygpath -u "$SRC_ROOT"`
else
EXEEXT_FOR_BUILD=
+ SRC_ROOT=`pwd`
fi
+AC_SUBST(SRC_ROOT)
AC_SUBST(EXEEXT_FOR_BUILD)
cat /dev/null > warn
@@ -9548,7 +9553,7 @@ else
echo > set_soenv.last
fi
-AC_CONFIG_FILES([ooo.lst set_soenv Makefile bin/repo-list desktop/scripts/soffice.sh])
+AC_CONFIG_FILES([ooo.lst set_soenv Makefile bin/repo-list desktop/scripts/soffice.sh build_env])
AC_OUTPUT
# make sure this is executable