summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2011-11-07 18:47:19 +0100
committerRene Engelhard <rene@debian.org>2011-11-08 01:01:13 +0100
commitbc7c4e378d77aa6960bcb98ec97081f00036b0e5 (patch)
tree570cfbcc9e1cc4a52a6f35e208d4ae7f75f439a1 /configure.in
parentadd actual $(MOZILLA_HEADERS_CFLAGS) to extensions' build (diff)
downloadcore-bc7c4e378d77aa6960bcb98ec97081f00036b0e5.tar.gz
core-bc7c4e378d77aa6960bcb98ec97081f00036b0e5.zip
Fixup the headers mozilla check to be up par with latest updates.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 5b772b05c44d..d96c65c1177b 100644
--- a/configure.in
+++ b/configure.in
@@ -1303,9 +1303,10 @@ AC_ARG_WITH(system-mozilla,
WITH_SYSTEM_MOZILLA=no)
AC_ARG_WITH(system-mozilla-headers,
- AS_HELP_STRING([--with-system-mozilla-headers],
- [Use mozilla headers provided by system instead of bundled ones. Needed for
- nsplugin])
+ AS_HELP_STRING([--with-system-mozilla-headers],
+ [Use mozilla headers provided by system instead of bundled ones. Needed for
+ nsplugin]),
+ [with_system_mozilla_headers="$with_system_libs"]
)
AC_ARG_WITH(system-gettext,
@@ -5979,15 +5980,14 @@ dnl ===================================================================
dnl Check for system mozilla headers
dnl ===================================================================
AC_MSG_CHECKING([which mozilla headers to use])
-if test -n "$with_system_mozilla_headers" -o -n "$with_system_headers" && \
- test "x$with_system_mozilla_headers" != "xno"; then
+if test "$with_system_mozilla_headers" = "xyes"; then
AC_MSG_RESULT([external])
SYSTEM_MOZILLA_HEADERS=YES
# First try npapi-sdk:
- PKG_CHECK_MODULES(MOZILLA_HEADERS, npapi-sdk, [LOCATED=yes], [LOCATED=NO])
+ PKG_CHECK_MODULES(MOZILLA_HEADERS, npapi-sdk, [LOCATED=yes], [LOCATED=no])
# Then go with libxul:
if test "x$LOCATED" != "xyes"; then
- PKG_CHECK_MODULES(MOZILLA_HEADERS, libxul, [LOCATED=yes], [LOCATED=NO])
+ PKG_CHECK_MODULES(MOZILLA_HEADERS, libxul, [LOCATED=yes], [LOCATED=no])
fi
# if still not found bail out
if test "x$LOCATED" != "xyes"; then