summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2011-10-15 17:44:01 +0000
committerRene Engelhard <rene@debian.org>2011-10-16 16:52:57 +0200
commit6923f3fc13f560fd0a2f4f8a12b6f4d45fb4da71 (patch)
tree507316424023d8c6261a2a3a09b538e000ea5b4a /configure.in
parentSome callcatcher cleaning (diff)
downloadcore-6923f3fc13f560fd0a2f4f8a12b6f4d45fb4da71.tar.gz
core-6923f3fc13f560fd0a2f4f8a12b6f4d45fb4da71.zip
don't grep /proc/cpuinfo but use getconf on Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d7b9a5c1702b..07e2e50553f4 100644
--- a/configure.in
+++ b/configure.in
@@ -6488,8 +6488,9 @@ if test -n "$with_system_lpsolve" -o -n "$with_system_libs" && \
# some systems need this. Like Ubuntu....
AC_CHECK_LIB(m, floor)
AC_CHECK_LIB(dl, dlopen)
+ AC_CHECK_LIB(colamd, colamd)
AC_CHECK_LIB(lpsolve55, make_lp, ,
- [ AC_MSG_ERROR(lpsolve library not found or too old.)], [])
+ [ AC_MSG_ERROR(lpsolve library not found or too old.)], [-L/usr/lib/lpsolve])
MINGW_EXTERNAL_DLLS="$MINGW_EXTERNAL_DLLS lpsolve55.dll"
else
AC_MSG_RESULT([internal])
@@ -9417,6 +9418,10 @@ else
BUILD_NCPUS=`sysctl -n hw.ncpu`
;;
+ Linux)
+ BUILD_NCPUS=`getconf _NPROCESSORS_ONLN`
+ ;;
+ # what else than above does profit here *and* has /proc?
*)
BUILD_NCPUS=`grep $'^processor\t*:' /proc/cpuinfo | wc -l`
;;