summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBjoern Michaelsen <bjoern.michaelsen@canonical.com>2011-12-22 01:05:58 +0100
committerBjoern Michaelsen <bjoern.michaelsen@canonical.com>2011-12-22 01:08:47 +0100
commita308f9172f86349c324a8cb07979f7b051811321 (patch)
tree07e1690601f6c9c00338a0a05658f9e386ebf8ed /configure.in
parentHeader/Footer,Page Break: fix bad test for printing mode (fdo#43962) (diff)
downloadcore-a308f9172f86349c324a8cb07979f7b051811321.tar.gz
core-a308f9172f86349c324a8cb07979f7b051811321.zip
Revert "Fix gmake detection for MacOSX"
This reverts commit cf33de27eb5e981d8a1fa76f6a9d72ce7174f10d. This breaks make bug 20033 detection on Linux. If this can not be reliably detected on OSX, just disable parallelism for GNU make 3.81 on OSX in general, but leave the detection intact for Linux.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 2 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 897403a9bbd3..8ef3cdb9caa2 100644
--- a/configure.in
+++ b/configure.in
@@ -2696,19 +2696,7 @@ if test "$_make_longver" -ge "038200" ; then
elif test "$_make_longver" -ge "038100" ; then
AC_MSG_RESULT([$GNUMAKE $_make_version])
AC_MSG_CHECKING([for GNU make bug 20033])
- dnl
- dnl FIXME: mktemp takes different arguments on different platforms:
- dnl http://stackoverflow.com/questions/2792675/how-portable-is-mktemp1
- dnl
- dnl -t means either 'use $TMPDIR' (OK) or 'the following is a template'.
- dnl and without 'the following is a template', a following template
- dnl is allowed, so this *may* work on *most* platforms
- dnl
- TESTGMAKEBUG20033=`mktemp -d -t MakefileXX`
- SHA1SUM=sha1sum
- if test "$_os" = "Darwin"; then
- SHA1SUM=shasum
- fi
+ TESTGMAKEBUG20033=`mktemp -d`
cat > $TESTGMAKEBUG20033/Makefile << EOF
A := \$(wildcard *.a)
@@ -2731,7 +2719,7 @@ define d2
endef
%.b : %.a
- \$(eval CHECKSUM := \$(word 1,\$(shell cat \$^ | $SHA1SUM))) \$(if \$(wildcard \$(CACHEDIR)/\$(CHECKSUM)),\
+ \$(eval CHECKSUM := \$(word 1,\$(shell cat \$^ | sha1sum))) \$(if \$(wildcard \$(CACHEDIR)/\$(CHECKSUM)),\
\$(call d1,\$(CHECKSUM)),\
\$(call d2,\$(CHECKSUM)))
EOF