summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEnrico Weigelt, metux ITS <metuxitservice@googlemail.com>2012-11-16 00:00:58 +0100
committerRene Engelhard <rene.engelhard.re@googlemail.com>2012-11-16 13:55:23 +0000
commit0e682df529bb9216e009da39c449dab29ccf2807 (patch)
treea56584aa2cac6d2cfc00c8011a3600bbdf785ddf /configure.ac
parentn#780277: select field when clicking it instead of having cursor before it (diff)
downloadcore-0e682df529bb9216e009da39c449dab29ccf2807.tar.gz
core-0e682df529bb9216e009da39c449dab29ccf2807.zip
renamed --enable-bluetooth to --enable-sdremote-bluetooth
The current configure option --enable-bluetooth is a bit misleading, it doesn't really tell what it's actually for. Therefore renamed it, so it's more clear that it's an sdremote backend using bluetooth. Change-Id: Ia8b46ee001ea112b80521baa502dcab2bb7e83aa Reviewed-on: https://gerrit.libreoffice.org/1086 Reviewed-by: Rene Engelhard <rene.engelhard.re@googlemail.com> Tested-by: Rene Engelhard <rene.engelhard.re@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 01272148ccf6..9b9b9905ced8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -860,11 +860,11 @@ AC_ARG_ENABLE(sdremote,
[Determines whether to enable Impress remote control.]),
,enable_sdremote=yes)
-AC_ARG_ENABLE(bluetooth,
- AS_HELP_STRING([--disable-bluetooth],
+AC_ARG_ENABLE(sdremote-bluetooth,
+ AS_HELP_STRING([--disable-sdremote-bluetooth],
[Determines whether to build sdremote with bluetooth support
- (via dbus)]),
-,enable_bluetooth=yes)
+ Requires: dbus]),
+,enable_sdremote_bluetooth=yes)
AC_ARG_ENABLE(gconf,
AS_HELP_STRING([--disable-gconf],
@@ -9524,12 +9524,12 @@ AC_MSG_CHECKING([whether to enable sd remotecontrol])
if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
AC_MSG_RESULT([yes])
ENABLE_SDREMOTE=YES
- AC_MSG_CHECKING([whether to enable bluetooth support])
- if test -n "$enable_bluetooth" -a "$enable_bluetooth" != "no"; then
+ AC_MSG_CHECKING([whether to enable sdremote via bluetooth support])
+ if test -n "$enable_sdremote_bluetooth" -a "$enable_sdremote_bluetooth" != "no"; then
if test "$OS" = "LINUX"; then
if test "$ENABLE_DBUS" = "TRUE"; then
AC_MSG_RESULT([yes])
- ENABLE_BLUETOOTH=YES
+ ENABLE_SDREMOTE_BLUETOOTH=YES
dnl ===================================================================
dnl Check for system bluez
dnl ===================================================================
@@ -9544,11 +9544,11 @@ if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
fi
else
AC_MSG_RESULT([no, dbus disabled])
- ENABLE_BLUETOOTH=NO
+ ENABLE_SDREMOTE_BLUETOOTH=NO
fi
else
AC_MSG_RESULT([no])
- ENABLE_BLUETOOTH=NO
+ ENABLE_SDREMOTE_BLUETOOTH=NO
fi
fi
else
@@ -9556,7 +9556,7 @@ else
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_SDREMOTE)
-AC_SUBST(ENABLE_BLUETOOTH)
+AC_SUBST(ENABLE_SDREMOTE_BLUETOOTH)
dnl ===================================================================
dnl Check whether the gtk 2.0 libraries are available.