summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@collabora.com>2014-03-13 11:03:04 +0100
committerMatúš Kukan <matus.kukan@collabora.com>2014-03-14 09:31:42 +0100
commitfc27a685d466dc380a8b68cd48f47db632ed3693 (patch)
tree3c9d7ec646b878d57742658e361b083d942e2078 /configure.ac
parentadd shlwapi (diff)
downloadcore-fc27a685d466dc380a8b68cd48f47db632ed3693.tar.gz
core-fc27a685d466dc380a8b68cd48f47db632ed3693.zip
Avoid duplicate symbols in libmerged for Windows too.
Export these symbols from sfx library. For cases when we link together more libraries, there are more symbols, so I've kept __attribute__((__weak__)) hack there. Change-Id: I8b7f6fc9bea479dca5062344c04b74c1f3eb36b2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 92ca7dd700ab..7c5d277d7ee1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12424,11 +12424,11 @@ if test -n "$enable_mergelibs" -a "$enable_mergelibs" != "no"; then
if test "$enable_mergelibs" = "all"; then
MERGELIBS="ALL"
URELIBS="TRUE"
+ AC_DEFINE(STATIC_LINKING)
else
MERGELIBS="CORE"
fi
AC_MSG_RESULT([yes])
- AC_DEFINE(STATIC_LINKING)
else
AC_MSG_RESULT([no])
fi