summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tlillqvist@suse.com>2012-12-23 00:22:01 +0200
committerTor Lillqvist <tlillqvist@suse.com>2012-12-23 00:27:46 +0200
commitbbfd7f0db44d6b7a848131213534f52dff3ab30c (patch)
treed4af71a961251cbb7d14567302c0c5b78e815d2c /configure.ac
parent--enable-foo=TRUE is not the normal way to do it (diff)
downloadcore-bbfd7f0db44d6b7a848131213534f52dff3ab30c.tar.gz
core-bbfd7f0db44d6b7a848131213534f52dff3ab30c.zip
Indent consistently
Change-Id: Ie2cdbf1291ec340053238b72dd155f20aa2aaddb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac173
1 files changed, 86 insertions, 87 deletions
diff --git a/configure.ac b/configure.ac
index 74d5a8cbab79..83def27bc473 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3032,16 +3032,16 @@ find_msvs()
{
# find Visual Studio 2012/2010/2008
for ver in 11.0 10.0 9.0; do
- reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VisualStudio/$ver/Setup/VS/ProductDir
- if test -n "$regvalue"; then
- vstest=$regvalue
- break
- fi
- reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VCExpress/$ver/Setup/VS/ProductDir
- if test -n "$regvalue"; then
- vstest=$regvalue
- break
- fi
+ reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VisualStudio/$ver/Setup/VS/ProductDir
+ if test -n "$regvalue"; then
+ vstest=$regvalue
+ break
+ fi
+ reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VCExpress/$ver/Setup/VS/ProductDir
+ if test -n "$regvalue"; then
+ vstest=$regvalue
+ break
+ fi
done
}
@@ -3049,16 +3049,16 @@ find_msvc()
{
# find Visual Studio 2012/2010/2008
for ver in 11.0 10.0 9.0; do
- reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VisualStudio/$ver/Setup/VC/ProductDir
- if test -n "$regvalue"; then
- vctest=$regvalue
- break
- fi
- reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VCExpress/$ver/Setup/VC/ProductDir
- if test -n "$regvalue"; then
- vctest=$regvalue
- break
- fi
+ reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VisualStudio/$ver/Setup/VC/ProductDir
+ if test -n "$regvalue"; then
+ vctest=$regvalue
+ break
+ fi
+ reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VCExpress/$ver/Setup/VC/ProductDir
+ if test -n "$regvalue"; then
+ vctest=$regvalue
+ break
+ fi
done
}
@@ -3067,7 +3067,7 @@ if test "$_os" = "WINNT"; then
if test "$WITH_MINGW" != "yes"; then
AC_MSG_CHECKING([for a friendly Microsoft C/C++ compiler installation path])
if test -z "$with_cl_home"; then
- find_msvc
+ find_msvc
if test "$BITNESS_OVERRIDE" = ""; then
if test -x "$vctest/bin/cl.exe"; then
with_cl_home=$vctest
@@ -4760,43 +4760,43 @@ dnl ===================================================================
find_csc()
{
if test $VCVER -eq 90; then
- reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/NET Framework Setup/NDP/v3.5/InstallPath"
- if test -n "$regvalue"; then
- csctest=$regvalue
- return
- fi
- reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/.NETFramework/InstallRoot
- if test -n "$regvalue"; then
- csctest=${regvalue}"v2.0.50727"
- fi
+ reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/NET Framework Setup/NDP/v3.5/InstallPath"
+ if test -n "$regvalue"; then
+ csctest=$regvalue
+ return
+ fi
+ reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/.NETFramework/InstallRoot
+ if test -n "$regvalue"; then
+ csctest=${regvalue}"v2.0.50727"
+ fi
else
- reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/NET Framework Setup/NDP/v4/Client/InstallPath"
- if test -n "$regvalue"; then
- csctest=$regvalue
- break
- fi
+ reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/NET Framework Setup/NDP/v4/Client/InstallPath"
+ if test -n "$regvalue"; then
+ csctest=$regvalue
+ break
+ fi
fi
}
find_al()
{
for x in `ls /proc/registry/HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft\ SDKs/Windows`; do
- reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft SDKs/Windows/$x/WinSDK-NetFx40Tools/InstallationFolder"
- if test -n "$regvalue" -a \( -f "$regvalue/al.exe" -o -f "$regvalue/bin/al.exe" \); then
- altest=$regvalue
- break
- fi
+ reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft SDKs/Windows/$x/WinSDK-NetFx40Tools/InstallationFolder"
+ if test -n "$regvalue" -a \( -f "$regvalue/al.exe" -o -f "$regvalue/bin/al.exe" \); then
+ altest=$regvalue
+ break
+ fi
done
}
find_dotnetsdk()
{
for ver in 1.1 2.0; do
- reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/.NETFramework/sdkInstallRootv$ver
- if test -n "$regvalue"; then
- frametest=$regvalue
- break
- fi
+ reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/.NETFramework/sdkInstallRootv$ver
+ if test -n "$regvalue"; then
+ frametest=$regvalue
+ break
+ fi
done
}
@@ -4804,25 +4804,25 @@ find_winsdk()
{
reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows Kits/Installed Roots/KitsRoot"
if test -n "$regvalue"; then
- winsdktest=$regvalue
- return
+ winsdktest=$regvalue
+ return
fi
reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft SDKs/Windows/CurrentInstallFolder"
if test -n "$regvalue"; then
- winsdktest=$regvalue
- return
+ winsdktest=$regvalue
+ return
fi
reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/MicrosoftSDK/Directories/Install Dir"
if test -n "$regvalue"; then
- winsdktest=$regvalue
- return
+ winsdktest=$regvalue
+ return
fi
for x in `ls /proc/registry/HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/MicrosoftSDK/InstalledSDKs`; do
- reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/MicrosoftSDK/InstalledSDKs/$x/Install Dir"
- if test -n "$regvalue"; then
- winsdktest=$regvalue
- break
- fi
+ reg_get_value "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/MicrosoftSDK/InstalledSDKs/$x/Install Dir"
+ if test -n "$regvalue"; then
+ winsdktest=$regvalue
+ break
+ fi
done
}
@@ -4830,67 +4830,67 @@ find_winsdk()
copy_msms()
{
for ver in 9.0 10.0 11.0; do
- reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VisualStudio/$ver/Setup/VS/MSMDir
- if test -n "$regvalue"; then
- if test -e "$regvalue/Microsoft_VC${VCVER}_CRT_x86.msm"; then
- msmdir=$regvalue
- break
- fi
+ reg_get_value HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/VisualStudio/$ver/Setup/VS/MSMDir
+ if test -n "$regvalue"; then
+ if test -e "$regvalue/Microsoft_VC${VCVER}_CRT_x86.msm"; then
+ msmdir=$regvalue
+ break
fi
+ fi
done
msmdir=`cygpath -d "$msmdir"`
msmdir=`cygpath -u "$msmdir"`
if test -z "$msmdir"; then
- AC_MSG_ERROR([Merge modules not found])
+ AC_MSG_ERROR([Merge modules not found])
fi
if test $VCVER -eq 90; then
- cp $msmdir/policy_9_0_Microsoft_VC90_CRT_x86.msm ./external/msm90
- if test $? -ne 0; then
- AC_MSG_ERROR([Failed to copy merge modules])
- fi
+ cp $msmdir/policy_9_0_Microsoft_VC90_CRT_x86.msm ./external/msm90
+ if test $? -ne 0; then
+ AC_MSG_ERROR([Failed to copy merge modules])
+ fi
fi
cp $msmdir/Microsoft_VC${VCVER}_CRT_x86.msm ./external/msm${VCVER}
if test $? -ne 0; then
- AC_MSG_ERROR([Failed to copy merge modules])
+ AC_MSG_ERROR([Failed to copy merge modules])
fi
cp $msmdir/Microsoft_VC${VCVER}_CRT_x64.msm ./external/msm${VCVER}
if test $? -ne 0; then
- AC_MSG_WARN([Failed to copy x64 merge modules, installation will lack the 64-bit Explorer extension])
+ AC_MSG_WARN([Failed to copy x64 merge modules, installation will lack the 64-bit Explorer extension])
fi
}
copy_msvc_dlls()
{
if test $CPUNAME == INTEL; then
- vsarch=x86
+ vsarch=x86
else
- vsarch=amd64
+ vsarch=amd64
fi
if test -f $with_cl_home/redist/$vsarch/Microsoft.VC${VCVER}.CRT/msvcp${VCVER}.dll; then
- vsdlldir=$with_cl_home/redist/$vsarch/Microsoft.VC${VCVER}.CRT
+ vsdlldir=$with_cl_home/redist/$vsarch/Microsoft.VC${VCVER}.CRT
else
- AC_MSG_ERROR([can not find VS dll $with_cl_home/redist/$vsarch/Microsoft.VC${VCVER}.CRT/msvcp${VCVER}.dll])
+ AC_MSG_ERROR([can not find VS dll $with_cl_home/redist/$vsarch/Microsoft.VC${VCVER}.CRT/msvcp${VCVER}.dll])
fi
cp $vsdlldir/msvcp${VCVER}.dll $vsdlldir/msvcr${VCVER}.dll ./external/msvcp${VCVER}
if test $VCVER == 90; then
- cp $vsdlldir/msvcm${VCVER}.dll $vsdlldir/Microsoft.VC90.CRT.manifest ./external/msvcp${VCVER}
- if test $? -ne 0; then
- AC_MSG_ERROR([Failed to copy VS dlls])
- fi
+ cp $vsdlldir/msvcm${VCVER}.dll $vsdlldir/Microsoft.VC90.CRT.manifest ./external/msvcp${VCVER}
+ if test $? -ne 0; then
+ AC_MSG_ERROR([Failed to copy VS dlls])
+ fi
fi
}
copy_dbghelp_dll()
{
if test ! -f ./external/dbghelp/dbghelp.dll -a -f $TARFILE_LOCATION/$DBGHELP_DLL; then
- cp $TARFILE_LOCATION/$DBGHELP_DLL ./external/dbghelp/dbghelp.dll;
+ cp $TARFILE_LOCATION/$DBGHELP_DLL ./external/dbghelp/dbghelp.dll;
fi
if test ! -f ./external/dbghelp/dbghelp.dll; then
- echo "dbghelp.dll is missing in external/dbghelp/."
+ echo "dbghelp.dll is missing in external/dbghelp/."
echo "Get it from the Microsoft site and put it there."
echo "(Note: Microsoft seems to enjoy changing the exact location of this file."
echo "You may have to search Microsoft's website.) Last time it was seen at:"
@@ -4900,8 +4900,8 @@ copy_dbghelp_dll()
}
if test "$build_os" = "cygwin"; then
- copy_msvc_dlls
- copy_dbghelp_dll
+ copy_msvc_dlls
+ copy_dbghelp_dll
dnl Check midl.exe
AC_PATH_PROG(MIDL_PATH, midl.exe)
@@ -4926,7 +4926,7 @@ if test "$build_os" = "cygwin"; then
fi
fi
if test -z "$MIDL_PATH"; then
- find_winsdk
+ find_winsdk
if test -x "$winsdktest/Bin/midl.exe"; then
MIDL_PATH="$winsdktest/Bin"
elif test -x "$winsdktest/Bin/$SDK_ARCH/midl.exe"; then
@@ -4955,7 +4955,7 @@ if test "$build_os" = "cygwin"; then
if test -x "$with_csc_path/csc.exe"; then
CSC_PATH="$with_csc_path"
else
- find_csc
+ find_csc
if test -x "$csctest/csc.exe"; then
CSC_PATH="$csctest"
fi
@@ -5013,15 +5013,15 @@ if test "$build_os" = "cygwin"; then
if test -n "$with_dotnet_framework_home"; then
with_dotnet_framework_home=`cygpath -u "$with_dotnet_framework_home"`
fi
- if test -f "$with_dotnet_framework_home/lib/mscoree.lib"; then
+ if test -f "$with_dotnet_framework_home/lib/mscoree.lib"; then
DOTNET_FRAMEWORK_HOME="$with_dotnet_framework_home"
fi
if test -z "$DOTNET_FRAMEWORK_HOME"; then
- find_dotnetsdk
+ find_dotnetsdk
if test -f "$frametest/lib/mscoree.lib"; then
DOTNET_FRAMEWORK_HOME="$frametest"
else
- find_winsdk
+ find_winsdk
if test -f "$winsdktest/lib/mscoree.lib" -o -f "$winsdktest/lib/win8/um/$SDK_ARCH/mscoree.lib"; then
DOTNET_FRAMEWORK_HOME="$winsdktest"
fi
@@ -5043,7 +5043,6 @@ if test "$build_os" = "cygwin"; then
PathFormat "$CSC_PATH"
CSC_PATH="$formatted_path"
-
fi
dnl ===================================================================