summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2012-12-31 12:41:31 +0100
committerDavid Tardon <dtardon@redhat.com>2012-12-31 12:41:47 +0100
commita084ea60680372efb7998f7369c9fc99eb85c50a (patch)
tree6d13d851a3ccb0c2de6447c3d39c0059eafda6ac /configure.ac
parentalways set library path (diff)
downloadcore-a084ea60680372efb7998f7369c9fc99eb85c50a.tar.gz
core-a084ea60680372efb7998f7369c9fc99eb85c50a.zip
do not second-guess the location of mingw sysroot
Change-Id: I669b6c7b90f2b803f68df86704b357967481f6ce
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index c74e1a24c2ee..8428abccb7ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5313,12 +5313,13 @@ dnl ===================================================================
dnl Set the MinGW sys-root
dnl ===================================================================
if test "$WITH_MINGW" = "yes"; then
- for sysroot in /usr/i686-w64-mingw32/sys-root/mingw; do
- if test -d "$sysroot"; then
- MINGW_SYSROOT="$sysroot"
- break
- fi
- done
+ AC_MSG_CHECKING([for MinGW sysroot])
+ sysroot=`$CC -print-sysroot`
+ AS_IF([test -d "$sysroot"],
+ [MINGW_SYSROOT="$sysroot"
+ AC_MSG_RESULT([$MINGW_SYSROOT])],
+ [AC_MSG_RESULT([not found])
+ AC_MSG_ERROR([cannot determine MinGW sysroot])])
fi
AC_SUBST([MINGW_SYSROOT])